Bug 270230 - Pinned watch displays 'argc =' instead of 'argc = 5'
Pinned watch displays 'argc =' instead of 'argc = 5'
Status: VERIFIED FIXED
Product: cnd
Classification: Unclassified
Component: Debugger
8.2
PC Solaris
: P2 (vote)
: 8.2
Assigned To: Maria Tishkova
issues@cnd
82patch2-verified
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2017-03-28 13:45 UTC by soldatov
Modified: 2017-04-19 08:50 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description soldatov 2017-03-28 13:45:20 UTC
No test failures if I use NetBeans 8.2 patch 1. With internal patches I see
stable failure in GDB suite on all platforms. On developer's machine this test fails for 22 builds.

Scenario:
- Create Welcome project
- Push Step Into context menu item in Projects tab
- Open Variables tab
- Add 'argc' variable
- Switch off 'Value' column in Variables tab
- Press "Finish Debugger Session" button on toolbar
- Push Step Into again
- Select 'argc'
==> tooltip appears (argc = 5)
- Pin watch
==> I see "argc =" only
Comment 1 Maria Tishkova 2017-03-29 13:10:03 UTC
Is it reproducible for NetBeans only?
Comment 2 soldatov 2017-03-29 13:24:25 UTC
No. I can reproduce this bug with Studio+Dbx too.
Comment 3 Maria Tishkova 2017-03-30 21:31:15 UTC
The problem was not about Value column.
They are different for Netbeans(gdb) and Studio(dbx).
GDB:
the problem was the value for incorrect GdbWatch was return in NativePinWatchValueProvider. The iterator took the first GdbWatch with the pinned expression and returned its value. That is incorrect. It should return value for the correct GdbWatch that has Watch inside with the Pin. As a result for gdb fix is just check for equals instead of equals for expression.
DBX:
for Dbx the problem was the pinned watch was a duplicate and was excluded from update watch value cycle. 

Fixed in enum for gdb:
changeset:   315001:e73cdd405423
branch:      release82
tag:         tip
user:        Maria Dalmatova <mromashova@netbeans.org>
date:        Fri Mar 31 00:23:04 2017 +0300
summary:     fixed bz#270230 - Pinned watch displays 'argc =' instead of 'argc = 5'

Fixed in sputnik for dbx:
changeset:   28411:8a148197b92f
tag:         tip
parent:      28367:9032d69bb406
user:        Maria Dalmatova <maria.tishkova@oracle.com>
date:        Fri Mar 31 00:28:13 2017 +0300
summary:     fixed bz#270230 - Pinned watch displays 'argc =' instead of 'argc = 5'
Comment 4 Quality Engineering 2017-04-02 02:35:56 UTC
Integrated into 'main-silver', will be available in build *201704020002* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)

Changeset: http://hg.netbeans.org/main-silver/rev/a0cf5e465ca0
User: Maria Dalmatova <mromashova@netbeans.org>
Log: fixed bz#270230 - Pinned watch displays 'argc =' instead of 'argc = 5'
the problem was we had 2 WatchVariable with the same expression but they were created for different Watch objects
as watch in Variables view was created earlier it was returned as a result of NativePinWatchValueProvider but as Variables view was closed the value was not recieved from the GDB, but it was ready for the second WatchVariable with the same expression but different Watch inside which were created for Pinned tooltip
(transplanted from e73cdd4054237bb67b84dba3d89a7b1159ee0788)
Comment 5 Quality Engineering 2017-04-08 03:08:06 UTC
Integrated into 'main-silver', will be available in build *201704080002* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)

Changeset: http://hg.netbeans.org/main-silver/rev/b36026d0aaa4
User: Maria Dalmatova <mromashova@netbeans.org>
Log: fixed bz#270230 - Pinned watch displays 'argc =' instead of 'argc = 5'
Comment 6 ilia 2017-04-13 10:47:04 UTC
https://netbeans.org/bugzilla/show_bug.cgi?id=270230 Changesets:
    http://hg.netbeans.org/releases/rev/e73cdd405423 # fixed bz#270230 - Pinned watch displays 'argc =' instead of 'argc = 5'
Comment 7 soldatov 2017-04-19 08:50:41 UTC
Verified in NetBeans IDE 8.2 (Build 201704181436)


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo