Bug 270132 - JDK9 can not be set up as a platform on Solaris
JDK9 can not be set up as a platform on Solaris
Status: RESOLVED FIXED
Product: java
Classification: Unclassified
Component: Platform
Dev
PC Solaris
: P2 (vote)
: Dev
Assigned To: Tomas Zezula
issues@java
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2017-03-20 12:34 UTC by Vladimir Voskresensky
Modified: 2017-03-22 02:43 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Vladimir Voskresensky 2017-03-20 12:34:50 UTC
Product Version: NetBeans IDE Dev (Build 20170320-02d5c30cca9f)
Java: 1.8.0_112; Java HotSpot(TM) 64-Bit Server VM 25.112-b15
Runtime: Java(TM) SE Runtime Environment 1.8.0_112-b15
System: SunOS version 5.11 running on amd64; UTF-8; en_US (nb)

Trying to add "/export1/devarea/jdk/jdk-9" as a new Java Platform.
From shell:
#/export1/devarea/jdk/jdk-9/bin/java -version
java version "9-ea"
Java(TM) SE Runtime Environment (build 9-ea+159)
Java HotSpot(TM) 64-Bit Server VM (build 9-ea+159, mixed mode)

From NB it fails with the following in log:
FINE [org.netbeans.modules.java.j2seplatform.wizard.NewJ2SEPlatform]: Executing: /export1/devarea/jdk/jdk-9/bin/java -classpath /export1/opt/netbeans/java/modules/ext/org-netbeans-modules-java-j2seplatform-probe.jar org.netbeans.modules.java.j2seplatform.wizard.SDKProbe /var/tmp/nb-platformdetect648257195510701299properties
INFO [org.netbeans.modules.java.j2seplatform.wizard.NewJ2SEPlatform]: Cannot execute probe process
java.io.IOException: Java process exit code: 6
    at org.netbeans.modules.java.j2seplatform.wizard.NewJ2SEPlatform.getSDKProperties(NewJ2SEPlatform.java:169)
[catch] at org.netbeans.modules.java.j2seplatform.wizard.NewJ2SEPlatform.run(NewJ2SEPlatform.java:119)
    at org.netbeans.modules.java.j2seplatform.wizard.DetectPanel$WizardPanel$1.run(DetectPanel.java:463)
    at org.openide.util.RequestProcessor$Task.run(RequestProcessor.java:1443)
    at org.netbeans.modules.openide.util.GlobalLookup.execute(GlobalLookup.java:68)
    at org.openide.util.lookup.Lookups.executeWith(Lookups.java:303)
    at org.openide.util.RequestProcessor$Processor.run(RequestProcessor.java:2058)
Comment 1 Tomas Zezula 2017-03-20 15:02:33 UTC
Seems Solaris specific.
Tomas H has a Solaris machine and is able to reproduce the problem.
I think it may be a problem with LD_LIBRARY_PATH exported in the ./platform/lib/nbexec.
But it's just a try.
Comment 2 Tomas Hurka 2017-03-20 16:03:07 UTC
It is caused by exporting LD_LIBRARY_PATH. We had the same problem before - see issue #234311.

Fixed in profiler-main.

changeset:   302726:e3da1537bce0
user:        Tomas Hurka <thurka@netbeans.org>
date:        Mon Mar 20 16:58:32 2017 +0100
summary:     bugfix #270132, setting of the LD_LIBRARY_PATH is unnecessary on JDK8
Comment 3 Quality Engineering 2017-03-22 02:43:33 UTC
Integrated into 'main-silver', will be available in build *201703220002* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)

Changeset: http://hg.netbeans.org/main-silver/rev/e3da1537bce0
User: Tomas Hurka <thurka@netbeans.org>
Log: bugfix #270132, setting of the LD_LIBRARY_PATH is unnecessary on JDK8


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo