Bug 269723 - Empty tooltip for variables in Debugger
Empty tooltip for variables in Debugger
Status: RESOLVED FIXED
Product: debugger
Classification: Unclassified
Component: Code
8.2
PC All
: P2 (vote)
: 8.2
Assigned To: Martin Entlicher
issues@debugger
82patch2-fixed
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2017-02-02 15:19 UTC by Geertjan Wielenga
Modified: 2017-05-13 22:37 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
screenshot1 (48.29 KB, image/png)
2017-02-02 15:19 UTC, Geertjan Wielenga
Details
screenshot2 (45.06 KB, image/png)
2017-02-02 15:20 UTC, Geertjan Wielenga
Details
screenshot3 (55.32 KB, image/png)
2017-02-02 15:20 UTC, Geertjan Wielenga
Details
screenshot4 (74.91 KB, image/png)
2017-05-13 14:06 UTC, ashrao
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Geertjan Wielenga 2017-02-02 15:19:42 UTC
Created attachment 163551 [details]
screenshot1

I created a single page HTML/JS application. I ran the project in both 
NetBeans IDE 8.1 and 8.2.

The screen shots attached are....

1) screen before choosing the the + button to inspect variable in 8.2.
2) popup in NetBeans 8.2
3) popup in NetBeans 8.1

I get this gray popup with all non-singleton variables in 8.2.

--------------- Hello World ---------------

<html>
        <head>
            <title></title>
            <meta charset="UTF-8">
            <meta name="viewport" content="width=device-width, 
initial-scale=1.0">

            <script 
src="http://ajax.googleapis.com/ajax/libs/jquery/3.1.1/jquery.min.js" 
type="text/javascript"></script>

        </head>

        <body>

            <div id="hello-world"></div>

            <script type="text/javascript">

                var title = $('#hello-world');
                title.text('hello world');

            </script>

        </body>
</html>

---------

If you cannot recreate the issue, let me know. I assume you have a Win7 
64 pro machine to test it on as it might be specific to the operating 
system.
Comment 1 Geertjan Wielenga 2017-02-02 15:20:07 UTC
Created attachment 163552 [details]
screenshot2
Comment 2 Geertjan Wielenga 2017-02-02 15:20:33 UTC
Created attachment 163553 [details]
screenshot3
Comment 3 Martin Entlicher 2017-02-03 12:03:50 UTC
I've reproduced that on Ubuntu Linux as well.
Comment 4 Martin Entlicher 2017-02-03 12:17:42 UTC
Fixed in dev:
http://hg.netbeans.org/jet-main/rev/36aef8e72d2b

and release82:
http://hg.netbeans.org/releases/rev/2db7c3813f83
Comment 5 Quality Engineering 2017-02-05 02:52:03 UTC
Integrated into 'main-silver', will be available in build *201702050002* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)

Changeset: http://hg.netbeans.org/main-silver/rev/36aef8e72d2b
User: mentlicher@netbeans.org
Log: #269723: Fixed content of expanded tooltip.
Comment 6 ashrao 2017-05-13 14:04:48 UTC
This is still happening on latest version of NB8.2. See screen shot below.
Comment 7 ashrao 2017-05-13 14:06:36 UTC
Created attachment 164313 [details]
screenshot4

The issue is still occurring in NB8.2 latest.
Comment 8 ashrao 2017-05-13 22:37:37 UTC
I assumed that this should have come through in some update by now, given that this issue was pushed to 8.2 branch in Feb. My Bad. Will change it back to resolved, but eagerly waiting for the fix to come through in an update. Apolgoies for any confusion.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo