Bug 269326 - ClassCastException: Cannot cast org.netbeans.modules.java.source.save.Reindenter$$Lambda$227/34841035 to javax.tools.DiagnosticListener
ClassCastException: Cannot cast org.netbeans.modules.java.source.save.Reinden...
Status: RESOLVED FIXED
Product: editor
Classification: Unclassified
Component: Formatting & Indentation
Dev
All All
: P1 with 3 votes (vote)
: Dev
Assigned To: Dusan Balek
issues@editor
EXCEPTIONS_REPORT
:
: 269634 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2016-12-14 08:13 UTC by Chiana
Modified: 2017-04-27 01:48 UTC (History)
7 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (4.33 KB, text/plain)
2016-12-14 08:13 UTC, Chiana
Details
stacktrace (6.28 KB, text/plain)
2016-12-14 08:33 UTC, Chiana
Details
messages.log without the -verbose:class option (56.63 KB, application/octet-stream)
2017-02-27 18:35 UTC, Alexandr Scherbatiy
Details
Run netbeans with the -J-verbose:class option (33.15 KB, application/octet-stream)
2017-02-27 18:55 UTC, Alexandr Scherbatiy
Details
stacktrace (4.56 KB, text/plain)
2017-04-02 20:34 UTC, Jiri Prox
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Chiana 2016-12-14 08:13:05 UTC
Build: NetBeans IDE Dev (Build 201612120001)
VM: Java HotSpot(TM) 64-Bit Server VM, 25.0-b62, Java(TM) SE Runtime Environment, 1.8.0-ea-b120
OS: Windows 8

User Comments:
Chiana: Still get this, did a clean reinstall and tried again, still persists




Stacktrace: 
java.lang.ClassCastException: Cannot cast org.netbeans.modules.java.source.save.Reindenter$$Lambda$227/34841035 to javax.tools.DiagnosticListener
   at java.lang.Class.cast(Class.java:3258)
   at java.lang.invoke.MethodHandles.constant(MethodHandles.java:2123)
   at java.lang.invoke.InnerClassLambdaMetafactory.buildCallSite(InnerClassLambdaMetafactory.java:216)
   at java.lang.invoke.LambdaMetafactory.metafactory(LambdaMetafactory.java:304)
   at java.lang.invoke.CallSite.makeSite(CallSite.java:289)
   at java.lang.invoke.MethodHandleNatives.linkCallSite(MethodHandleNatives.java:296)
Comment 1 Chiana 2016-12-14 08:13:08 UTC
Created attachment 163228 [details]
stacktrace
Comment 2 Chiana 2016-12-14 08:33:47 UTC
Created attachment 163229 [details]
stacktrace

Tried to use "surround with try/catch" tool.
Comment 3 Dusan Balek 2017-01-26 08:37:41 UTC
*** Bug 269634 has been marked as a duplicate of this bug. ***
Comment 4 mps77 2017-02-16 17:47:27 UTC
Showstopper critical musthave
Comment 5 Dusan Balek 2017-02-22 13:00:06 UTC
Unfortunately, I cannot reproduce the problem. If you are still able to reproduce it on your side, could you please run your IDE with -verbose:class switch and attach the console output to this issue? Thanks.
Comment 6 Alexandr Scherbatiy 2017-02-27 18:35:15 UTC
Created attachment 163722 [details]
messages.log without the -verbose:class option
Comment 7 Alexandr Scherbatiy 2017-02-27 18:55:51 UTC
Created attachment 163723 [details]
Run netbeans with the -J-verbose:class option
Comment 8 Jiri Prox 2017-04-02 20:34:10 UTC
Created attachment 164002 [details]
stacktrace

Editing java file
Comment 9 Dusan Balek 2017-04-26 09:09:59 UTC
Fixed in jet-main.

http://hg.netbeans.org/jet-main/rev/3020e848e952
Comment 10 Quality Engineering 2017-04-27 01:48:11 UTC
Integrated into 'main-silver', will be available in build *201704270002* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)

Changeset: http://hg.netbeans.org/main-silver/rev/3020e848e952
User: Dusan Balek <dbalek@netbeans.org>
Log: Issue #269326 - ClassCastException: Cannot cast org.netbeans.modules.java.source.save.Reindenter$$Lambda$227/34841035 to javax.tools.DiagnosticListener - fixed.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo