Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 269322 - "Run again" is broken on ant and maven project
"Run again" is broken on ant and maven project
Status: CLOSED DUPLICATE of bug 252959
Product: java
Classification: Unclassified
Component: JUnit
Dev
PC Windows 10 x64
: P3 (vote)
: TBD
Assigned To: Theofanis Oikonomou
junit-issues@java
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2016-12-13 14:52 UTC by skygo
Modified: 2016-12-14 22:52 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description skygo 2016-12-13 14:52:25 UTC
Trying to run an individual test in Test Results view is broken


Following the test [1] section 4 item 10,  in synergy I encounter an issue tryning to do "run again" on testDivide() 

-- In Ant
the following error is shown


userURL\AppData\Local\NetBeans\Cache\8.2\executor-snippets\junit.xml:141: The following error occurred while executing this line:
userURL\AppData\Local\NetBeans\Cache\8.2\executor-snippets\junit.xml:78: Invalid specification of test methods: "teststorun.CalculatorTest.testDivide"; expected: comma-separated list of valid Java identifiers
BUILD FAILED (total time: 0 seconds

-- In Maven
no test are run


[1]http://services.netbeans.org/synergy/client/app/#/title/junit_testing_support/
Comment 1 Jiri Kovalsky 2016-12-14 22:52:22 UTC
I believe this is already known problem. Thanks for your report anyway.

*** This bug has been marked as a duplicate of bug 252959 ***
Comment 2 Jiri Kovalsky 2016-12-14 22:52:41 UTC
Closing.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo