Bug 269304 - When cursor, page up/down or home, end keys are pressed in an editor the disk is accessed constantly
When cursor, page up/down or home, end keys are pressed in an editor the disk...
Status: RESOLVED FIXED
Product: editor
Classification: Unclassified
Component: Actions/Menu/Toolbar
8.2
All All
: P1 with 1 vote (vote)
: 8.2
Assigned To: Miloslav Metelka
issues@editor
82patch1-fixed
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2016-12-12 03:49 UTC by ytx
Modified: 2017-04-07 13:14 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
IDE log (70.17 KB, text/plain)
2016-12-12 03:49 UTC, ytx
Details

Note You need to log in before you can comment on or make changes to this bug.
Description ytx 2016-12-12 03:49:20 UTC
Product Version = NetBeans IDE 8.2 (Build 201609300101)
Operating System = Linux version 4.4.0-53-generic running on amd64
Java; VM; Vendor = 1.8.0_111
Runtime = OpenJDK 64-Bit Server VM 25.111-b14

Reproducibility: Happens every time

STEPS:
  * Open a java or xml editor;
  * Press any cursor (left, right, up, down), page up/down, home or end keys the disk will be access.

ACTUAL:
  disk is access constantly (if the key is press and hold then the disk is accessed for every repeat, even if the caret at the beginning of the file (i.e. there is no room (space) for the caret to move to) the disk anyway is accessed.

EXPECTED:
  no excessive disk access.
Comment 1 ytx 2016-12-12 03:49:28 UTC
Created attachment 163206 [details]
IDE log
Comment 2 FrankBO 2017-04-03 08:39:48 UTC
Holding down any cursor key results in constantly writing 150 K/s to disk.

Very annoying with loud hard drives and probably unnecessarily aging SDD drives.

Should be fixed with high priority.

Downgraded to NB 8.1
Comment 3 FrankBO 2017-04-03 09:17:13 UTC
It's related to file 

USERDIR/config/Preferences/org/netbeans/modules/uihandler.properties

which is written in high frequency
Comment 4 Tomas Hurka 2017-04-05 17:57:52 UTC
This is caused by issue #262714. The dev. builds works fine, but release82 branch is missing changeset http://hg.netbeans.org/main-silver/rev/8f112f9b30fb. This change enables editor action logging only if netbeans are started with -J-Dorg.netbeans.editor.ui.actions.logging.detailed=true
Comment 5 Martin Balin 2017-04-06 08:17:28 UTC
Deserves a special patch for NetBeans 8.2.
Comment 6 Miloslav Metelka 2017-04-06 13:40:51 UTC
Integrated into release82:
8f112f9b30fb transplanted to 3fa24caee530
Comment 7 Miloslav Metelka 2017-04-07 13:14:01 UTC
Apologies, added version numbers increase:
http://hg.netbeans.org/releases/rev/8c8e89c6764c


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo