Bug 269282 - NPE in unit tests
NPE in unit tests
Status: VERIFIED FIXED
Product: cnd
Classification: Unclassified
Component: Remote
Dev
All All
: P3 (vote)
: 8.2
Assigned To: Vladimir Kvashin
issues@cnd
82patch1-verified
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2016-12-09 11:34 UTC by Vladimir Kvashin
Modified: 2016-12-14 14:18 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Vladimir Kvashin 2016-12-09 11:34:54 UTC
in hudson/job/cnd-test-ubuntu.x86_64/13082/
and other tests:

SEVERE: Error in RequestProcessor org.netbeans.modules.cnd.makeproject.api.ProjectActionSupport$EventsProcessorImpl
org.openide.util.RequestProcessor$SlowItem: task failed due to: java.lang.NullPointerException
    at org.openide.util.RequestProcessor.post(RequestProcessor.java:420)
    at org.netbeans.modules.cnd.makeproject.api.ProjectActionSupport.submitTask(ProjectActionSupport.java:281)
    at org.netbeans.modules.cnd.makeproject.api.ProjectActionSupport.fireActionPerformed(ProjectActionSupport.java:278)
    at org.netbeans.modules.cnd.makeproject.MakeActionProviderImpl$1$1.runImpl(MakeActionProviderImpl.java:343)
    at org.netbeans.modules.cnd.utils.NamedRunnable.run(NamedRunnable.java:62)
    at org.openide.util.RequestProcessor$Task.run(RequestProcessor.java:1443)
    at org.netbeans.modules.openide.util.GlobalLookup.execute(GlobalLookup.java:68)
    at org.openide.util.lookup.Lookups.executeWith(Lookups.java:303)
    at org.openide.util.RequestProcessor$Processor.run(RequestProcessor.java:2058)
Caused by: java.lang.NullPointerException
    at org.netbeans.modules.cnd.remote.sync.FtpSyncWorker.synchronizeImpl(FtpSyncWorker.java:184)
    at org.netbeans.modules.cnd.remote.sync.FtpSyncWorker.startup(FtpSyncWorker.java:782)
    at org.netbeans.modules.cnd.remote.sync.RemoteBuildProjectActionHandler.execute(RemoteBuildProjectActionHandler.java:180)
    at org.netbeans.modules.cnd.makeproject.api.ProjectActionSupport$EventsProcessorImpl.run(ProjectActionSupport.java:589)
    ... 4 more
Comment 1 Vladimir Kvashin 2016-12-09 11:36:03 UTC
This is probably caused by regression descriped in issue 269281.
Anyhow the code shows that null checks are done in some places, but are absent in other places.
Comment 2 Vladimir Kvashin 2016-12-09 11:56:58 UTC
fixed in 5be103dfcc13 on enum/release82
Comment 3 Quality Engineering 2016-12-11 02:35:31 UTC
Integrated into 'main-silver', will be available in build *201612110001* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)

Changeset: http://hg.netbeans.org/main-silver/rev/846a9d946296
User: Vladimir Kvashin <vkvashin@netbeans.org>
Log: fixed #269282 - NPE in unit tests
(transplanted from 5be103dfcc13b5f7ea5be60ea8f5696c14f08874)


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo