Bug 269199 - Editor ignore C++11 standard in standard headers
Editor ignore C++11 standard in standard headers
Status: VERIFIED FIXED
Product: cnd
Classification: Unclassified
Component: Editor
Dev
PC Solaris
: P2 (vote)
: 8.2
Assigned To: Vladimir Voskresensky
issues@cnd
82patch1-verified
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2016-12-01 14:41 UTC by Alexander Simon
Modified: 2016-12-15 09:30 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alexander Simon 2016-12-01 14:41:52 UTC
Steps to reproduce bug:
- create C/C++ application with C++11 standard and Oracle Developer Studio
- open main.cpp file
- add include:
#include <functional>
- hyper-link to functional header
See redness in header in line:
   mem_fn(_Tp _Class::*) noexcept;
Editor does not know keyword "noexcept" and show wrong message "Unable to resolve identifier noexcept".
Comment 1 Vladimir Voskresensky 2016-12-01 14:58:51 UTC
simplified case:
create C/C++ application with C++11 standard
use Open File to open 'functional' 
see not colored noexcept
Comment 2 Vladimir Voskresensky 2016-12-06 18:51:06 UTC
Another problematic case:
do not have any opened NB project, but try to open system file "functional"
=> although default for C++ files in options is C++11, but whole file is grayed out
Comment 3 Quality Engineering 2016-12-08 02:36:21 UTC
Integrated into 'main-silver', will be available in build *201612080001* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)

Changeset: http://hg.netbeans.org/main-silver/rev/f6f153e9d0b4
User: Vladimir Voskresensky <vv159170@netbeans.org>
Log: fixing #269199 - Editor ignore C++11 standard in standard headers
- give names to filters
(transplanted from 94a6ce1845e087c9af34b4135ae3c547c687973d)
Comment 4 Quality Engineering 2016-12-11 02:35:17 UTC
Integrated into 'main-silver', will be available in build *201612110001* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)

Changeset: http://hg.netbeans.org/main-silver/rev/90476dd64dab
User: Vladimir Voskresensky <vv159170@netbeans.org>
Log: fixing #269199 - Editor ignore C++11 standard in standard headers
- fixed NPE when closing IDE and getting parser errors
(transplanted from 09c1751d722ca7d7b5cbd87ba433bb23d40778ef)
Comment 5 Quality Engineering 2016-12-13 02:35:02 UTC
Integrated into 'main-silver', will be available in build *201612130001* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)

Changeset: http://hg.netbeans.org/main-silver/rev/95e8ce74f858
User: Vladimir Voskresensky <vv159170@netbeans.org>
Log: fixing #269199 - Editor ignore C++11 standard in standard headers
- fixed spell in trace
(transplanted from 035ac5a5521864bf077b941d3c6526a23e2fcf70)
Comment 6 Vladimir Voskresensky 2016-12-14 11:01:13 UTC
Considered as fixed. Other discovered issues are going to be tracked by another IZs.
Comment 7 petrk 2016-12-14 11:14:10 UTC
*** Bug 269323 has been marked as a duplicate of this bug. ***
Comment 8 soldatov 2016-12-15 09:30:08 UTC
Verified in NetBeans IDE 8.2 (Build 201612141242)


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo