Bug 269176 - significant performance hit adding/deleting lines while editing
significant performance hit adding/deleting lines while editing
Status: RESOLVED FIXED
Product: cnd
Classification: Unclassified
Component: Debugger
Dev
PC Linux
: P1 (vote)
: 8.2
Assigned To: Maria Tishkova
issues@cnd
82patch2-fixed
:
: 269175 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2016-11-30 00:51 UTC by tbrunhoff
Modified: 2017-04-13 10:38 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
selfSampler (58.39 KB, application/octet-stream)
2016-11-30 00:51 UTC, tbrunhoff
Details
selfSampler (82.80 KB, application/octet-stream)
2016-11-30 00:52 UTC, tbrunhoff
Details
selfSampler (110.51 KB, application/octet-stream)
2016-11-30 00:53 UTC, tbrunhoff
Details

Note You need to log in before you can comment on or make changes to this bug.
Description tbrunhoff 2016-11-30 00:51:39 UTC
Created attachment 163087 [details]
selfSampler

A few of the files I am editing take a significant hit when editing. It appears to happen only when adding or deleting lines in a file, and when doing so, the ide freezes for 2 to 7 seconds. This particular file is 5200 lines of

I followed this description (http://wiki.netbeans.org/FaqProfileMeNow) and captured three snapshots. Unfortunately, this web page might be out of date, because it did not open any of the snapshots.

There were other slowness events during this time reported as http://statistics.netbeans.org/analytics/detail.do?id=227374
However, those were marked as debugger slowness. The attached selfsampler files are just for one added line of code.
Comment 1 tbrunhoff 2016-11-30 00:52:25 UTC
Created attachment 163088 [details]
selfSampler
Comment 2 tbrunhoff 2016-11-30 00:53:06 UTC
Created attachment 163089 [details]
selfSampler
Comment 3 Tomas Hurka 2017-04-05 13:43:45 UTC
Most of the time in AWT is spent in org.netbeans.modules.cnd.debugger.common2.debugger.DebuggerAnnotation.propertyChange()

Reassigning to cnd/debugger.
Comment 4 Maria Tishkova 2017-04-06 08:53:32 UTC
Indeed it is CND debugger performance problem
Comment 5 Maria Tishkova 2017-04-06 14:30:16 UTC
fixed on enum/releases82
will be delivered to trunk later this week
fix minimizes notification in AWT thread


changeset:   315195:926583018866
branch:      release82
tag:         tip
user:        Maria Dalmatova <mromashova@netbeans.org>
date:        Thu Apr 06 17:27:38 2017 +0300
summary:     added fix to bz#269176 -  significant performance hit adding/deleting lines while editing  spec version increment

changeset:   315194:4d991879f5a3
branch:      release82
user:        Maria Dalmatova <mromashova@netbeans.org>
date:        Thu Apr 06 17:27:34 2017 +0300
summary:     fixed bz#269176 - significant performance hit adding/deleting lines while editing
Comment 6 Maria Tishkova 2017-04-10 11:37:59 UTC
*** Bug 269175 has been marked as a duplicate of this bug. ***
Comment 7 Quality Engineering 2017-04-11 01:51:12 UTC
Integrated into 'main-silver', will be available in build *201704110002* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)

Changeset: http://hg.netbeans.org/main-silver/rev/db75b258a071
User: Maria Dalmatova <mromashova@netbeans.org>
Log: fixed bz#269176 - significant performance hit adding/deleting lines while editing
avoid multiple notifications as they are done in AWT thread, notify once
(transplanted from 4d991879f5a3582c2977ab4a21339032372f6e83)
Comment 8 ilia 2017-04-13 10:38:35 UTC
https://netbeans.org/bugzilla/show_bug.cgi?id=269176 Changesets:
    http://hg.netbeans.org/releases/rev/4d991879f5a3 # fixed bz#269176 - significant performance hit adding/deleting lines while editing
    http://hg.netbeans.org/releases/rev/926583018866 # added fix to bz#269176 -  significant performance hit adding/deleting lines while editing  spec version increment


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo