Bug 269032 - Launchers can not be modified through dialog: do not use asLines or fix it
Launchers can not be modified through dialog: do not use asLines or fix it
Status: VERIFIED FIXED
Product: cnd
Classification: Unclassified
Component: Project
8.2
All Solaris
: P2 (vote)
: 8.2
Assigned To: Alexander Simon
issues@cnd
82patch1-verified
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2016-11-18 13:25 UTC by Vladimir Voskresensky
Modified: 2016-12-08 13:57 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
proposed work around (3.44 KB, patch)
2016-11-21 10:46 UTC, Alexander Simon
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Vladimir Voskresensky 2016-11-18 13:25:21 UTC
when I modify launchers in dialog and press OK, changes are not applied and in log I see:
org.netbeans.modules.masterfs.filebasedfs.utils.FSException: Cannot get exclusive access to /export/devarea/sputnik-jclank/contrib/JConvert/nbproject/private/launcher.properties@1edd53dc:ff83fe7 (probably opened for reading).
	at org.netbeans.modules.masterfs.filebasedfs.utils.FSException.io(FSException.java:118)
	at org.netbeans.modules.masterfs.filebasedfs.fileobjects.MutualExclusionSupport.addResource(MutualExclusionSupport.java:103)
	at org.netbeans.modules.masterfs.filebasedfs.fileobjects.FileObj.getOutputStream(FileObj.java:129)
	at org.netbeans.modules.masterfs.filebasedfs.fileobjects.FileObj.getOutputStream(FileObj.java:104)
	at org.openide.filesystems.FileObject.getOutputStream(FileObject.java:815)
	at org.netbeans.modules.cnd.makeproject.ui.launchers.actions.LaunchersConfig.save(LaunchersConfig.java:351)
	at org.netbeans.modules.cnd.makeproject.ui.launchers.actions.LaunchersConfig.save(LaunchersConfig.java:314)
	at org.netbeans.modules.cnd.makeproject.ui.launchers.actions.LaunchersPanel.save(LaunchersPanel.java:225)
	at org.netbeans.modules.cnd.makeproject.ui.launchers.actions.ManageLaunchers.invoke(ManageLaunchers.java:61)
	at org.netbeans.modules.cnd.makeproject.ui.actions.MakeProjectManageLaunchersAction.performAction(MakeProjectManageLaunchersAction.java:76)
	at org.openide.util.actions.NodeAction$DelegateAction$1.run(NodeAction.java:586)
	at org.openide.util.actions.ActionInvoker$1.run(ActionInvoker.java:95)
	at org.openide.util.actions.ActionInvoker.doPerformAction(ActionInvoker.java:116)
	at org.openide.util.actions.ActionInvoker.invokeAction(ActionInvoker.java:99)
	at org.openide.util.actions.NodeAction$DelegateAction.actionPerformed(NodeAction.java:583)
	at javax.swing.AbstractButton.fireActionPerformed(AbstractButton.java:2022)
	at javax.swing.AbstractButton$Handler.actionPerformed(AbstractButton.java:2348)
	at javax.swing.DefaultButtonModel.fireActionPerformed(DefaultButtonModel.java:402)
	at javax.swing.DefaultButtonModel.setPressed(DefaultButtonModel.java:259)
	at javax.swing.AbstractButton.doClick(AbstractButton.java:376)
	at javax.swing.plaf.basic.BasicMenuItemUI.doClick(BasicMenuItemUI.java:833)
	at javax.swing.plaf.basic.BasicMenuItemUI$Handler.mouseReleased(BasicMenuItemUI.java:877)
	at java.awt.Component.processMouseEvent(Component.java:6533)
	at javax.swing.JComponent.processMouseEvent(JComponent.java:3324)
	at java.awt.Component.processEvent(Component.java:6298)
	at java.awt.Container.processEvent(Container.java:2236)
	at java.awt.Component.dispatchEventImpl(Component.java:4889)
	at java.awt.Container.dispatchEventImpl(Container.java:2294)
	at java.awt.Component.dispatchEvent(Component.java:4711)
	at java.awt.LightweightDispatcher.retargetMouseEvent(Container.java:4888)
	at java.awt.LightweightDispatcher.processMouseEvent(Container.java:4525)
	at java.awt.LightweightDispatcher.dispatchEvent(Container.java:4466)
	at java.awt.Container.dispatchEventImpl(Container.java:2280)
	at java.awt.Window.dispatchEventImpl(Window.java:2746)
	at java.awt.Component.dispatchEvent(Component.java:4711)
	at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:758)
	at java.awt.EventQueue.access$500(EventQueue.java:97)
	at java.awt.EventQueue$3.run(EventQueue.java:709)
	at java.awt.EventQueue$3.run(EventQueue.java:703)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:76)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:86)
	at java.awt.EventQueue$4.run(EventQueue.java:731)
	at java.awt.EventQueue$4.run(EventQueue.java:729)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:76)
	at java.awt.EventQueue.dispatchEvent(EventQueue.java:728)
	at org.netbeans.core.TimableEventQueue.dispatchEvent(TimableEventQueue.java:159)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:201)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:116)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:105)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:101)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:93)
	at java.awt.EventDispatchThread.run(EventDispatchThread.java:82)
Caused by: 
Caused by: java.lang.Throwable: opened stream here
	at org.netbeans.modules.masterfs.filebasedfs.fileobjects.MutualExclusionSupport$Closeable.populateStack(MutualExclusionSupport.java:178)
	at org.netbeans.modules.masterfs.filebasedfs.fileobjects.MutualExclusionSupport$Closeable.<init>(MutualExclusionSupport.java:174)
	at org.netbeans.modules.masterfs.filebasedfs.fileobjects.MutualExclusionSupport$Closeable.<init>(MutualExclusionSupport.java:165)
	at org.netbeans.modules.masterfs.filebasedfs.fileobjects.MutualExclusionSupport.addResource(MutualExclusionSupport.java:111)
	at org.netbeans.modules.masterfs.filebasedfs.fileobjects.FileObj.getInputStream(FileObj.java:237)
	at org.openide.filesystems.FileObjectLineIterator.initReader(FileObjectLineIterator.java:158)
	at org.openide.filesystems.FileObjectLineIterator.<init>(FileObjectLineIterator.java:70)
	at org.openide.filesystems.FileObjectLines.<init>(FileObjectLines.java:58)
	at org.openide.filesystems.FileObject.asLines(FileObject.java:793)
	at org.netbeans.modules.cnd.makeproject.ui.launchers.actions.LaunchersConfig.load(LaunchersConfig.java:117)
	at org.netbeans.modules.cnd.makeproject.ui.launchers.actions.LaunchersConfig.load(LaunchersConfig.java:105)
	at org.netbeans.modules.cnd.makeproject.ui.launchers.actions.LaunchersPanel.<init>(LaunchersPanel.java:156)
	at org.netbeans.modules.cnd.makeproject.ui.launchers.actions.ManageLaunchers.invoke(ManageLaunchers.java:56)
	at org.netbeans.modules.cnd.makeproject.ui.actions.MakeProjectManageLaunchersAction.performAction(MakeProjectManageLaunchersAction.java:76)
	at org.openide.util.actions.NodeAction$DelegateAction$1.run(NodeAction.java:586)
	at org.openide.util.actions.ActionInvoker$1.run(ActionInvoker.java:95)
	at org.openide.util.actions.ActionInvoker.doPerformAction(ActionInvoker.java:116)
	at org.openide.util.actions.ActionInvoker.invokeAction(ActionInvoker.java:99)
	at org.openide.util.actions.NodeAction$DelegateAction.actionPerformed(NodeAction.java:583)
	at javax.swing.AbstractButton.fireActionPerformed(AbstractButton.java:2022)
	at javax.swing.AbstractButton$Handler.actionPerformed(AbstractButton.java:2348)
	at javax.swing.DefaultButtonModel.fireActionPerformed(DefaultButtonModel.java:402)
	at javax.swing.DefaultButtonModel.setPressed(DefaultButtonModel.java:259)
	at javax.swing.AbstractButton.doClick(AbstractButton.java:376)
	at javax.swing.plaf.basic.BasicMenuItemUI.doClick(BasicMenuItemUI.java:833)
	at javax.swing.plaf.basic.BasicMenuItemUI$Handler.mouseReleased(BasicMenuItemUI.java:877)
	at java.awt.Component.processMouseEvent(Component.java:6533)
	at javax.swing.JComponent.processMouseEvent(JComponent.java:3324)
	at java.awt.Component.processEvent(Component.java:6298)
	at java.awt.Container.processEvent(Container.java:2236)
	at java.awt.Component.dispatchEventImpl(Component.java:4889)
	at java.awt.Container.dispatchEventImpl(Container.java:2294)
	at java.awt.Component.dispatchEvent(Component.java:4711)
	at java.awt.LightweightDispatcher.retargetMouseEvent(Container.java:4888)
	at java.awt.LightweightDispatcher.processMouseEvent(Container.java:4525)
	at java.awt.LightweightDispatcher.dispatchEvent(Container.java:4466)
	at java.awt.Container.dispatchEventImpl(Container.java:2280)
	at java.awt.Window.dispatchEventImpl(Window.java:2746)
	at java.awt.Component.dispatchEvent(Component.java:4711)
	at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:758)
	at java.awt.EventQueue.access$500(EventQueue.java:97)
	at java.awt.EventQueue$3.run(EventQueue.java:709)
	at java.awt.EventQueue$3.run(EventQueue.java:703)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:76)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:86)
	at java.awt.EventQueue$4.run(EventQueue.java:731)
	at java.awt.EventQueue$4.run(EventQueue.java:729)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:76)
	at java.awt.EventQueue.dispatchEvent(EventQueue.java:728)
	at org.netbeans.core.TimableEventQueue.dispatchEvent(TimableEventQueue.java:159)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:201)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:116)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:105)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:101)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:93)
	at java.awt.EventDispatchThread.run(EventDispatchThread.java:82)
Comment 1 Vladimir Voskresensky 2016-11-18 13:56:24 UTC
100% reproducible
open JConvert
close IDE
open IDE
when IDE loaded project, run Print Simple Test from Run submenu
Go to Launchers Manager dialog
try to modify any private launcher, press OK
=> exception
Launchers can not be used anymore
Comment 2 Alexander Simon 2016-11-18 14:02:23 UTC
Cannot reproduce the bug
Comment 3 Vladimir Voskresensky 2016-11-18 14:47:19 UTC
the same in 8.2 from enum

extra message:
INFO [cnd.logger]: getExecutableFromRunCommand() returned non-absolute pathdist/Solaris_Release/GNU-Solaris-x86/jconvert
java.lang.Exception: getExecutableFromRunCommand() returned non-absolute pathdist/Solaris_Release/GNU-Solaris-x86/jconvert
@[ProjectActionSupport.tasks]
[catch] at org.netbeans.modules.cnd.utils.CndUtils.assertTrueInConsole(CndUtils.java:222)
	at org.netbeans.modules.cnd.utils.CndUtils.assertTrueInConsole(CndUtils.java:287)
	at org.netbeans.modules.cnd.makeproject.api.ProjectActionEvent.getExecutable(ProjectActionEvent.java:199)
	at org.netbeans.modules.cnd.makeproject.api.ProjectActionSupport$EventsProcessorImpl.checkExecutable(ProjectActionSupport.java:690)
	at org.netbeans.modules.cnd.makeproject.api.ProjectActionSupport$EventsProcessorImpl.run(ProjectActionSupport.java:471)
	at org.openide.util.RequestProcessor$Task.run(RequestProcessor.java:1443)
	at org.netbeans.modules.openide.util.GlobalLookup.execute(GlobalLookup.java:68)
	at org.openide.util.lookup.Lookups.executeWith(Lookups.java:303)
	at org.openide.util.RequestProcessor$Processor.run(RequestProcessor.java:2058)
Comment 4 Vladimir Voskresensky 2016-11-18 14:47:24 UTC
Product Version: NetBeans IDE 8.2 (Build 20161118-13ee6f16f094)
Java: 1.8.0_102; Java HotSpot(TM) 64-Bit Server VM 25.102-b14
Runtime: Java(TM) SE Runtime Environment 1.8.0_102-b14
System: SunOS version 5.11 running on amd64; UTF-8; en_US (nb)
User directory: /var/tmp/vvoskres/check_launchers
Cache directory: /var/tmp/vvoskres/check_launchers/var/cache
Comment 5 Vladimir Voskresensky 2016-11-18 14:51:07 UTC
This is the message for 8.2
INFO [cnd.logger]: getExecutableFromRunCommand() returned non-absolute pathdist/Solaris_Release/GNU-Solaris-x86/jconvert
java.lang.Exception: getExecutableFromRunCommand() returned non-absolute pathdist/Solaris_Release/GNU-Solaris-x86/jconvert
@[ProjectActionSupport.tasks]
[catch] at org.netbeans.modules.cnd.utils.CndUtils.assertTrueInConsole(CndUtils.java:222)
	at org.netbeans.modules.cnd.utils.CndUtils.assertTrueInConsole(CndUtils.java:287)
	at org.netbeans.modules.cnd.makeproject.api.ProjectActionEvent.getExecutable(ProjectActionEvent.java:199)
	at org.netbeans.modules.cnd.makeproject.api.ProjectActionSupport$EventsProcessorImpl.checkExecutable(ProjectActionSupport.java:690)
	at org.netbeans.modules.cnd.makeproject.api.ProjectActionSupport$EventsProcessorImpl.run(ProjectActionSupport.java:471)
	at org.openide.util.RequestProcessor$Task.run(RequestProcessor.java:1443)
	at org.netbeans.modules.openide.util.GlobalLookup.execute(GlobalLookup.java:68)
	at org.openide.util.lookup.Lookups.executeWith(Lookups.java:303)
	at org.openide.util.RequestProcessor$Processor.run(RequestProcessor.java:2058)
org.netbeans.modules.masterfs.filebasedfs.utils.FSException: Cannot get exclusive access to /export/devarea/sputnik-jclank/contrib/JConvert/nbproject/private/launcher.properties@1edd53dc:5e877b09 (probably opened for reading).
	at org.netbeans.modules.masterfs.filebasedfs.utils.FSException.io(FSException.java:118)
	at org.netbeans.modules.masterfs.filebasedfs.fileobjects.MutualExclusionSupport.addResource(MutualExclusionSupport.java:103)
	at org.netbeans.modules.masterfs.filebasedfs.fileobjects.FileObj.getOutputStream(FileObj.java:129)
	at org.netbeans.modules.masterfs.filebasedfs.fileobjects.FileObj.getOutputStream(FileObj.java:104)
	at org.openide.filesystems.FileObject.getOutputStream(FileObject.java:815)
	at org.netbeans.modules.cnd.makeproject.ui.launchers.actions.LaunchersConfig.save(LaunchersConfig.java:351)
	at org.netbeans.modules.cnd.makeproject.ui.launchers.actions.LaunchersConfig.save(LaunchersConfig.java:314)
	at org.netbeans.modules.cnd.makeproject.ui.launchers.actions.LaunchersPanel.save(LaunchersPanel.java:225)
	at org.netbeans.modules.cnd.makeproject.ui.launchers.actions.ManageLaunchers.invoke(ManageLaunchers.java:61)
	at org.netbeans.modules.cnd.makeproject.ui.actions.MakeProjectManageLaunchersAction.performAction(MakeProjectManageLaunchersAction.java:76)
	at org.openide.util.actions.NodeAction$DelegateAction$1.run(NodeAction.java:586)
	at org.openide.util.actions.ActionInvoker$1.run(ActionInvoker.java:95)
	at org.openide.util.actions.ActionInvoker.doPerformAction(ActionInvoker.java:116)
	at org.openide.util.actions.ActionInvoker.invokeAction(ActionInvoker.java:99)
	at org.openide.util.actions.NodeAction$DelegateAction.actionPerformed(NodeAction.java:583)
	at javax.swing.AbstractButton.fireActionPerformed(AbstractButton.java:2022)
	at javax.swing.AbstractButton$Handler.actionPerformed(AbstractButton.java:2348)
	at javax.swing.DefaultButtonModel.fireActionPerformed(DefaultButtonModel.java:402)
	at javax.swing.DefaultButtonModel.setPressed(DefaultButtonModel.java:259)
	at javax.swing.AbstractButton.doClick(AbstractButton.java:376)
	at javax.swing.plaf.basic.BasicMenuItemUI.doClick(BasicMenuItemUI.java:833)
	at javax.swing.plaf.basic.BasicMenuItemUI$Handler.mouseReleased(BasicMenuItemUI.java:877)
	at java.awt.Component.processMouseEvent(Component.java:6533)
	at javax.swing.JComponent.processMouseEvent(JComponent.java:3324)
	at java.awt.Component.processEvent(Component.java:6298)
	at java.awt.Container.processEvent(Container.java:2236)
	at java.awt.Component.dispatchEventImpl(Component.java:4889)
	at java.awt.Container.dispatchEventImpl(Container.java:2294)
	at java.awt.Component.dispatchEvent(Component.java:4711)
	at java.awt.LightweightDispatcher.retargetMouseEvent(Container.java:4888)
	at java.awt.LightweightDispatcher.processMouseEvent(Container.java:4525)
	at java.awt.LightweightDispatcher.dispatchEvent(Container.java:4466)
	at java.awt.Container.dispatchEventImpl(Container.java:2280)
	at java.awt.Window.dispatchEventImpl(Window.java:2746)
	at java.awt.Component.dispatchEvent(Component.java:4711)
	at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:758)
	at java.awt.EventQueue.access$500(EventQueue.java:97)
	at java.awt.EventQueue$3.run(EventQueue.java:709)
	at java.awt.EventQueue$3.run(EventQueue.java:703)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:76)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:86)
	at java.awt.EventQueue$4.run(EventQueue.java:731)
	at java.awt.EventQueue$4.run(EventQueue.java:729)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:76)
	at java.awt.EventQueue.dispatchEvent(EventQueue.java:728)
	at org.netbeans.core.TimableEventQueue.dispatchEvent(TimableEventQueue.java:159)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:201)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:116)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:105)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:101)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:93)
	at java.awt.EventDispatchThread.run(EventDispatchThread.java:82)
Caused by: 
Caused by: java.lang.Throwable: opened stream here
	at org.netbeans.modules.masterfs.filebasedfs.fileobjects.MutualExclusionSupport$Closeable.populateStack(MutualExclusionSupport.java:178)
	at org.netbeans.modules.masterfs.filebasedfs.fileobjects.MutualExclusionSupport$Closeable.<init>(MutualExclusionSupport.java:174)
	at org.netbeans.modules.masterfs.filebasedfs.fileobjects.MutualExclusionSupport$Closeable.<init>(MutualExclusionSupport.java:165)
	at org.netbeans.modules.masterfs.filebasedfs.fileobjects.MutualExclusionSupport.addResource(MutualExclusionSupport.java:111)
	at org.netbeans.modules.masterfs.filebasedfs.fileobjects.FileObj.getInputStream(FileObj.java:237)
	at org.openide.filesystems.FileObjectLineIterator.initReader(FileObjectLineIterator.java:158)
	at org.openide.filesystems.FileObjectLineIterator.<init>(FileObjectLineIterator.java:70)
	at org.openide.filesystems.FileObjectLines.<init>(FileObjectLines.java:58)
	at org.openide.filesystems.FileObject.asLines(FileObject.java:793)
	at org.netbeans.modules.cnd.makeproject.ui.launchers.actions.LaunchersConfig.load(LaunchersConfig.java:117)
	at org.netbeans.modules.cnd.makeproject.ui.launchers.actions.LaunchersConfig.load(LaunchersConfig.java:105)
	at org.netbeans.modules.cnd.makeproject.ui.launchers.actions.LaunchersPanel.<init>(LaunchersPanel.java:156)
	at org.netbeans.modules.cnd.makeproject.ui.launchers.actions.ManageLaunchers.invoke(ManageLaunchers.java:56)
	at org.netbeans.modules.cnd.makeproject.ui.actions.MakeProjectManageLaunchersAction.performAction(MakeProjectManageLaunchersAction.java:76)
	at org.openide.util.actions.NodeAction$DelegateAction$1.run(NodeAction.java:586)
	at org.openide.util.actions.ActionInvoker$1.run(ActionInvoker.java:95)
	at org.openide.util.actions.ActionInvoker.doPerformAction(ActionInvoker.java:116)
	at org.openide.util.actions.ActionInvoker.invokeAction(ActionInvoker.java:99)
	at org.openide.util.actions.NodeAction$DelegateAction.actionPerformed(NodeAction.java:583)
	at javax.swing.AbstractButton.fireActionPerformed(AbstractButton.java:2022)
	at javax.swing.AbstractButton$Handler.actionPerformed(AbstractButton.java:2348)
	at javax.swing.DefaultButtonModel.fireActionPerformed(DefaultButtonModel.java:402)
	at javax.swing.DefaultButtonModel.setPressed(DefaultButtonModel.java:259)
	at javax.swing.AbstractButton.doClick(AbstractButton.java:376)
	at javax.swing.plaf.basic.BasicMenuItemUI.doClick(BasicMenuItemUI.java:833)
	at javax.swing.plaf.basic.BasicMenuItemUI$Handler.mouseReleased(BasicMenuItemUI.java:877)
	at java.awt.Component.processMouseEvent(Component.java:6533)
	at javax.swing.JComponent.processMouseEvent(JComponent.java:3324)
	at java.awt.Component.processEvent(Component.java:6298)
	at java.awt.Container.processEvent(Container.java:2236)
	at java.awt.Component.dispatchEventImpl(Component.java:4889)
	at java.awt.Container.dispatchEventImpl(Container.java:2294)
	at java.awt.Component.dispatchEvent(Component.java:4711)
	at java.awt.LightweightDispatcher.retargetMouseEvent(Container.java:4888)
	at java.awt.LightweightDispatcher.processMouseEvent(Container.java:4525)
	at java.awt.LightweightDispatcher.dispatchEvent(Container.java:4466)
	at java.awt.Container.dispatchEventImpl(Container.java:2280)
	at java.awt.Window.dispatchEventImpl(Window.java:2746)
	at java.awt.Component.dispatchEvent(Component.java:4711)
	at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:758)
	at java.awt.EventQueue.access$500(EventQueue.java:97)
	at java.awt.EventQueue$3.run(EventQueue.java:709)
	at java.awt.EventQueue$3.run(EventQueue.java:703)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:76)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:86)
	at java.awt.EventQueue$4.run(EventQueue.java:731)
	at java.awt.EventQueue$4.run(EventQueue.java:729)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:76)
	at java.awt.EventQueue.dispatchEvent(EventQueue.java:728)
	at org.netbeans.core.TimableEventQueue.dispatchEvent(TimableEventQueue.java:159)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:201)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:116)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:105)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:101)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:93)
	at java.awt.EventDispatchThread.run(EventDispatchThread.java:82)
Comment 6 Vladimir Voskresensky 2016-11-18 14:51:38 UTC
Launchers doesn't work at all, rising to P1. Please, investigate on my system.
Tell me any flags you'd like me to run with.
Comment 7 Alexander Simon 2016-11-18 14:53:20 UTC
Please investigate on your system.
Comment 8 Vladimir Voskresensky 2016-11-18 15:11:41 UTC
the reason could be the size of my heavily used file which is 67K 
We can not use getLines method which is incorrect in platform
Comment 9 Vladimir Voskresensky 2016-11-18 18:06:23 UTC
Or someone needs to fix FileObjectLineIterator.initReader for files bigger than 64K
Comment 10 Alexander Simon 2016-11-21 10:46:05 UTC
Created attachment 162968 [details]
proposed work around
Comment 11 Alexander Simon 2016-11-23 15:12:53 UTC
work around was committed in enum, branch release82, change set 9d4c015d0100
Comment 12 Quality Engineering 2016-12-03 03:03:40 UTC
Integrated into 'main-silver', will be available in build *201612030001* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)

Changeset: http://hg.netbeans.org/main-silver/rev/b2ecd8ee9a15
User: Alexander Simon <alexvsimon@netbeans.org>
Log: work around Bug 269032 - Launchers can not be modified through dialog
- do not use bogus FileObject.asLines() method
(transplanted from 9d4c015d01001b70d3ce8b04ca2838125733171a)
Comment 13 soldatov 2016-12-08 13:57:45 UTC
Verified in internal NetBeans 8,2 patch 1 build.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo