Bug 268698 - NullPointerException when attaching debugger without specifying a project
NullPointerException when attaching debugger without specifying a project
Status: VERIFIED FIXED
Product: cnd
Classification: Unclassified
Component: Debugger
8.2
All All
: P3 (vote)
: 8.2
Assigned To: Vladimir Kvashin
issues@cnd
82patch1-verified
:
: 268679 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2016-10-26 19:43 UTC by francis.chiss
Modified: 2016-12-13 09:07 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description francis.chiss 2016-10-26 19:43:13 UTC
See also statistics.netbeans.org/analytics/detail.do?id=226946

When I try to "Attach Debugger...", I'm presented with a dropdown where I pick a Host, I can specify a filter and then I can pick an executable from the list. So far so good.

In 8.1, I used to leave the "Project" field empty (<no project>) because the application I need to debug is quite complex and is composed of multiple executables launched with a complex set of scripts. When I pressed "Ok" I presume Gdb would just be given the path of the exe I had just selected in the list.

Now in 8.2, if I leave the "Project" field empty, I have the following exception:

java.lang.NullPointerException
	at org.netbeans.modules.cnd.api.remote.RemoteSyncSupport.getPathMap(RemoteSyncSupport.java:95)
	at org.netbeans.modules.cnd.makeproject.api.ProjectActionSupport$EventsProcessorImpl.checkExecutable(ProjectActionSupport.java:732)
	at org.netbeans.modules.cnd.makeproject.api.ProjectActionSupport$EventsProcessorImpl.run(ProjectActionSupport.java:440)
	at org.openide.util.RequestProcessor$Task.run(RequestProcessor.java:1443)
	at org.netbeans.modules.openide.util.GlobalLookup.execute(GlobalLookup.java:68)
	at org.openide.util.lookup.Lookups.executeWith(Lookups.java:303)
[catch] at org.openide.util.RequestProcessor$Processor.run(RequestProcessor.java:2058)


----------------------

My workaround is to copy the path of the executable, specify my project and then paste the path in the subsequent dialog. Could the path of the clicked executable could at least be the default selection? The exe I want is nowhere near my project folder, and the only exe's I'm presented with are those found somewhere in my Home folder because "No executable specified in  project".

Thanks for the good work, I much prefer doing C++ dev in NetBeans than Eclipse!
Comment 1 Vladimir Kvashin 2016-10-27 06:44:59 UTC
Thank you for the detailed description. The bug is 100% reproducible. It will be fixed shortly.
Comment 2 Vladimir Kvashin 2016-10-27 08:13:00 UTC
*** Bug 268679 has been marked as a duplicate of this bug. ***
Comment 3 Vladimir Kvashin 2016-10-27 08:51:53 UTC
It's a regression caused by
http://hg.netbeans.org/cnd-main/rev/3318e8b0470f
And it is also caused by the absence of the null check in remote.
So it's kind of both remote and debugger issue.
I fixed it in enum repo, change set 8307394dd236
Comment 4 Quality Engineering 2016-10-31 02:58:37 UTC
Integrated into 'main-silver', will be available in build *201610310002* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)

Changeset: http://hg.netbeans.org/main-silver/rev/93faa928ce70
User: Vladimir Kvashin <vkvashin@netbeans.org>
Log: fixed #268698 - NullPointerException when attaching debugger without specifying a project
(transplanted from 8307394dd2369c635707d2d2b77e56631fe7ed5f)
Comment 5 soldatov 2016-12-13 09:07:36 UTC
Verified in NetBeans IDE 8.2 (Build 201612122312)


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo