Bug 26868 - Java API is not mentioned in upgrade guide
Java API is not mentioned in upgrade guide
Status: VERIFIED FIXED
Product: usersguide
Classification: Unclassified
Component: Java
3.x
PC Linux
: P1 (vote)
: 3.x
Assigned To: Svata Dedic
issues@java
:
: 26867 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2002-08-29 10:16 UTC by Jaroslav Tulach
Modified: 2003-02-04 14:01 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jaroslav Tulach 2002-08-29 10:16:26 UTC
I've noticed that Java Classpath API is not
advertised in 
http://www.netbeans.org/download/dev/javadoc/OpenAPIs/org/openide/doc-files/upgrade.html
because the API played important role in our
transition plan from 3.x to 4.0 classpath model I
consider this as a major flaw.

Please fix it (at least in main trunk).
Comment 1 Jaroslav Tulach 2002-08-29 10:17:29 UTC
*** Issue 26867 has been marked as a duplicate of this issue. ***
Comment 2 Jaroslav Tulach 2002-08-29 10:18:16 UTC
Probably responsibility of developers than John. Reassigned to Svata.
Comment 3 Jesse Glick 2002-08-29 15:55:56 UTC
In CVS: openide/api/doc/org/openide/doc-files/upgrade.html
Comment 4 Svata Dedic 2002-08-30 08:38:31 UTC
Commited (to trunk).
Comment 5 Jan Becicka 2002-10-15 15:35:23 UTC
VERIFIED
Comment 6 _ mihmax 2002-11-24 15:17:17 UTC
Please, commit to release341 branch,

Thank you in advance,
Maxym Mykhalchuk, Merak Release Coordinator
Comment 7 Jan Becicka 2002-11-25 10:10:33 UTC
Well, this is just an issue in documentation. Moreover this document
is not part of NB 3.4 distribution. I suggest to remove the
3.4.1_CANDIDATE keyword. Any objections?
Comment 8 _ mihmax 2002-11-25 13:06:19 UTC
No objections, I did it myself, if you say it's not necessary for 3.4
/ 3.4.1

Sincere, Max
Comment 9 Jesse Glick 2002-11-26 23:12:53 UTC
Yes, I think generally we don't bother merging API docs fixes, since
the API developer can always look at the trunk version anyway...
although there is some reason to want to look at the APIs as they
exist for the version you are using, there are also reasons to want to
see the latest documentation.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo