Bug 268584 - std::array doesn't appear in Code Completion list in first file
std::array doesn't appear in Code Completion list in first file
Status: VERIFIED FIXED
Product: cnd
Classification: Unclassified
Component: Code Completion
8.2
PC Solaris
: P3 (vote)
: 8.2
Assigned To: Alexander Simon
issues@cnd
82patch1-verified
:
: 268639 268676 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2016-10-19 10:32 UTC by soldatov
Modified: 2016-12-07 13:21 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
proposed patch (12.67 KB, patch)
2016-10-19 10:48 UTC, Alexander Simon
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description soldatov 2016-10-19 10:32:27 UTC
Scenario:
- Launch IDE with fresh user directory
- Push "New Project..." button on toolbar
- Select C/C++/Fortran|C/C++/Fortran Application category
- Press Next button
- Switch off "Create Main File" checkbox
- Push Finish button
- Select "Sources Files" folder and press "New File..." button
- Select C++/C++ Source File
- Press Next and Finish buttons
- Type such code in editor:
int main() {

}
- Save file
- Call Project Properties window
- Set Build|C++ Compiler|C++ Standard = C++11
- Press OK button
- Type std::arr in main() and press Ctrl-Space
==> I don't see 'std::array'

Workaround: Call "Code Assistance|Reparse Project" context menu item
Comment 1 Alexander Simon 2016-10-19 10:48:44 UTC
Created attachment 162553 [details]
proposed patch
Comment 2 Alexander Simon 2016-10-19 10:49:18 UTC
Vladimir V, please review patch.
Comment 3 Vladimir Kvashin 2016-10-19 10:56:29 UTC
(In reply to Alexander Simon from comment #2)
> Vladimir V, please review patch.
You meant Vladimir K, as I understand.
The proposed fix looks reasonable.
Comment 4 Alexander Simon 2016-10-19 12:57:06 UTC
fixed in enum, branch release82, change set 71a988a8c251
Comment 5 Quality Engineering 2016-10-22 02:16:55 UTC
Integrated into 'main-silver', will be available in build *201610220002* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)

Changeset: http://hg.netbeans.org/main-silver/rev/e4c98137898a
User: Alexander Simon <alexvsimon@netbeans.org>
Log: fixed Bug 268584 std::array doesn't appear in Code Completion list in first file
(transplanted from 71a988a8c251544bb73e979d0d7ffef50e8765f7)
Comment 6 Alexander Simon 2016-10-26 11:40:30 UTC
additional fix in enum, branch release82, change set: 36a317af77da
- do not export private class
Comment 7 Alexander Simon 2016-10-26 11:43:33 UTC
*** Bug 268676 has been marked as a duplicate of this bug. ***
Comment 8 Quality Engineering 2016-10-31 02:58:33 UTC
Integrated into 'main-silver', will be available in build *201610310002* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)

Changeset: http://hg.netbeans.org/main-silver/rev/ceb96502b7db
User: Alexander Simon <alexvsimon@netbeans.org>
Log: fixed Bug 268584 std::array doesn't appear in Code Completion list in first file
- do not export private class
(transplanted from 36a317af77da15ac7176c8ab0b4bbb4ce13bee36)
Comment 9 Alexander Simon 2016-11-02 14:01:23 UTC
*** Bug 268639 has been marked as a duplicate of this bug. ***
Comment 10 soldatov 2016-12-07 13:21:01 UTC
Verified in internal NetBeans 8,2 patch 1 build.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo