Bug 268427 - Uploading NB8.2 Plugin fails
Uploading NB8.2 Plugin fails
Status: RESOLVED FIXED
Product: www
Classification: Unclassified
Component: Web Content
8.2
PC Linux
: P1 with 2 votes (vote)
: TBD
Assigned To: Jan Pirek
Jan Pirek
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2016-10-09 13:32 UTC by etrof
Modified: 2016-10-14 14:36 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description etrof 2016-10-09 13:32:36 UTC
Uploading a Plugin NBM for NB8.2 fails with following error message:



    ERROR: archive seems to be missing Info/info.xml manifest file
    Error: There is moduleauthor attribute missing in the manifest file. See wiki for more info on plugin requirements.
    Error: There is OpenIDE-Module-Short-Description attribute missing in the manifest file. See wiki for more info on plugin requirements.
    Error: There is no license specified in the manifest file. See wiki for more info on plugin requirements.


This happened with two plugins I wanted to upload. Both contain the infos mentioned in the error message (actually, both are only compiled for NB8.2 and are already in the Plugin Portal for earlier versions).

Reproducing:

1. Select the Plugin in 'My Plugins'
2. "Add Binary"
3. Enter description, select v8.2 and select file to upload
4. "Save Plugin"
5. Error is shown as above
Comment 2 Jan Pirek 2016-10-10 07:35:46 UTC
Hello,
there was lack of free disc space which most probably caused this issue - plugins were not extracted for info.xml inspection and therefore the error message.

I have cleared some space.

Can you please try again and let us know if it's working fine?
Comment 3 jockel 2016-10-10 09:23:40 UTC
Works now for me.
Comment 4 etrof 2016-10-14 14:36:30 UTC
@Jan Pirek: Works for me too and I have updated my plugins successfully. Thank you!


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo