Bug 268361 - 95% requests to remote agent are from remote VCS
95% requests to remote agent are from remote VCS
Status: VERIFIED FIXED
Product: cnd
Classification: Unclassified
Component: Remote VCS
8.1
All All
: P2 (vote)
: 8.2
Assigned To: Vladimir Kvashin
issues@cnd
82patch1-verified
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2016-10-05 17:08 UTC by Vladimir Kvashin
Modified: 2016-12-09 12:12 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Vladimir Kvashin 2016-10-05 17:08:25 UTC
I did the following:
- added a remote host
- added its root directory to facorites

Since the IDE was launched with the flag -J-Dremote.support.logger.level=FINEST
I was able to see how many requests to remote agent (fs_server) IDE did.

There were 5980 requests!
5708 requests were from remote VCS.
Only 272 requests (4.5%) were from other components
And neither of top-level directories were under VCS!

This should be addressed.
(I have a very simple idea, but let's not mix the problem statement with ideas how to fix)
Comment 1 Vladimir Kvashin 2016-10-06 13:13:29 UTC
There is a funny story about that: to access and manage remote files on a slow file system (that reside in US), our QA use DbxTool. Valery just told me that it works faster and more stable than IDE. And that's exactly because remote VCS is OFF in DbxTool.
Comment 2 Vladimir Kvashin 2016-10-06 13:20:02 UTC
The proposed solution:
1) There should be an "Automatic VCS discovery" option
2) If the option is OFF, then there should be a menu item on remote folders that allows to switch it ON

The questions are
a) whether to turn the option to OFF by default (I think it should be OFF)
b) how should the menu item in (2) look like. I would propose "Turn VCS discovery ON", so user does not specify the particular VCS and specific folder, just IDE performs its automatic discovery in this folder and its children.
c) should there be a place in options that contain the list of all folders automatic discovery is allowed? (I think this would be fine, but not necessary=
Comment 3 Vladimir Kvashin 2016-10-06 14:36:56 UTC
As a temporary solution, I propose to use just a -J-Dversioning.allowedFolders command line switch (note that we already have -J-Dversioning.forbiddenFolders one)
Comment 4 Vladimir Kvashin 2016-11-10 10:57:42 UTC
There is an evidence from out QA that this really slows down the IDE.

QA guys use NetBeans to access remote directories in US, view and edit files, etc. They found that DbxTool works much faster and much more stable than IDE. DbxTool does not support rempote VCS, so my assumption was that it's exactly the reason of better behaviour.

This assumption was recently confirmed: as soon as these guys added 
-J-Dremote.vcs.suport=false 
IDE command line option (which switches remote VCS off), IDE behaved as "good" as DbxTool does - it became much faster and much more stable.

We need to address this issue in the patch.
Comment 5 Vladimir Kvashin 2016-12-07 11:09:49 UTC
fixed in 63b7c38a886c, bcaf05cdfc7b on enum/release82
(change set bcaf05cdfc7b also contains fix for issue 269205)


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo