Bug 268324 - REGRESSION: incorrect Is Overridden annotation
REGRESSION: incorrect Is Overridden annotation
Status: VERIFIED FIXED
Product: cnd
Classification: Unclassified
Component: Navigation
8.1
All All
: P2 (vote)
: 8.2
Assigned To: petrk
issues@cnd
82patch1-verified
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2016-10-03 15:09 UTC by Vladimir Voskresensky
Modified: 2016-12-09 12:09 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Vladimir Voskresensky 2016-10-03 15:09:30 UTC
open JConvert, DeclJavaPrinter.h and check annotation for i.e. private PrettyPrintRawCallArgumens and public static isJavaInterface. Both has crossed "Is Overridden" annotation, but if click on it, then IDE jumps to usual definition. Which is OK, because neither private method nor static has any "overridden" candidates at all
Comment 1 Vladimir Voskresensky 2016-10-03 15:11:55 UTC
the same issue for functions from namespace ConvertUtils. Have a look at function declarations in ConvertUtils.h (i.e. isClangOrLLVMUserCodePath)
Comment 2 Alexander Simon 2016-10-03 15:17:02 UTC
Please provide the simplest test case
Comment 3 Vladimir Voskresensky 2016-10-03 15:31:02 UTC
Do you have access to source JConvert code? 
Could you try, please, functions mentioned in bug. 
Or you can not reproduce the issue?
Comment 4 Alexander Simon 2016-10-05 18:44:44 UTC
Why it is P2? Downgrade to P3.
Comment 5 Vladimir Voskresensky 2016-10-06 14:05:18 UTC
(In reply to Alexander Simon from comment #4)
> Why it is P2? Downgrade to P3.
Because it is a "regression" which is worth to investigate rather sooner than later.
Comment 6 Vladimir Voskresensky 2016-10-17 09:13:29 UTC
restored priority to track regression
Comment 7 Alexander Simon 2016-10-17 13:53:34 UTC
result of fixing bug #257899
Comment 8 petrk 2016-10-18 15:48:23 UTC
Fixed at enum: 311918:b2aae6276fb8
Comment 9 Quality Engineering 2016-10-22 02:16:49 UTC
Integrated into 'main-silver', will be available in build *201610220002* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)

Changeset: http://hg.netbeans.org/main-silver/rev/53000859d72d
User: Petr Kudryavtsev <petrk@netbeans.org>
Log: Fixed #268324 - REGRESSION: incorrect Is Overridden annotation
(transplanted from b2aae6276fb8dac752ff30335856974a6358d8de)
Comment 10 petrk 2016-12-09 11:26:37 UTC
Verified


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo