Bug 268322 - Generation of NetBeans 8.2 Plugin Portal Update Center catalog is broken
Generation of NetBeans 8.2 Plugin Portal Update Center catalog is broken
Status: VERIFIED FIXED
Product: updatecenters
Classification: Unclassified
Component: Pluginportal
8.2
PC Linux
: P1 (vote)
: TBD
Assigned To: Jan Pirek
issues@updatecenters
:
: 268364 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2016-10-03 14:15 UTC by Jiri Kovalsky
Modified: 2016-10-06 07:35 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jiri Kovalsky 2016-10-03 14:15:03 UTC
Due to some unrecognised property it is not possible to generate NetBeans 8.2 Plugin Portal Update Center catalog [1] which remains totally empty at the moment. This might be related in the output log:

[makeupdatedesc] WARNING: 'org.apache.xerces.jaxp.SAXParserImpl: Property 'http://javax.xml.XMLConstants/property/accessExternalDTD' is not recognized.'
[makeupdatedesc] No updater.jar specified, cannot validate /tmp/nbms/updates.xml against DTD
[gzip] Building: /tmp/nbms/updates.xml.gz

[1] http://plugins.netbeans.org/nbpluginportal/updates/8.2/catalog.xml

Honzo, can you please investigate this issue? Thanks!
Comment 1 Jiri Kovalsky 2016-10-05 18:48:47 UTC
*** Bug 268364 has been marked as a duplicate of this bug. ***
Comment 2 Jiri Kovalsky 2016-10-06 06:58:19 UTC
Thanks to Tomáš Hůrka we were able to manually generate the 8.2 Plugin Catalogue so at least the latest and approved plugins are now available for NetBeans 8.2 users directly from the IDE.

However, why automated generation fails is still under investigation.
Comment 3 Jiri Kovalsky 2016-10-06 07:35:20 UTC
And the problems is fixed. Now the automatic regeneration of module catalogues for 8.2 should work fine. Please reopen if there are still some problems.
Comment 4 Jiri Kovalsky 2016-10-06 07:35:44 UTC
Closing


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo