Bug 268284 - [HeapWalker] Strings in UI preview are displayed incorrectly
[HeapWalker] Strings in UI preview are displayed incorrectly
Status: VERIFIED FIXED
Product: profiler
Classification: Unclassified
Component: Base
8.0
All All
: P3 (vote)
: 8.2
Assigned To: Tomas Hurka
issues@profiler
82patch1-verified
: JDK_9, VISUALVM
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2016-09-30 13:29 UTC by Tomas Hurka
Modified: 2016-12-13 13:36 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tomas Hurka 2016-09-30 13:29:44 UTC
1) Open attached heap dump https://netbeans.org/projects/profiler/downloads/download/Heapdumps/heapdump-1449144851503.hprof.gz

2) In Overview tab clink on link under 'Application windows'.

3) Texts in UI preview are incorrect.

Problem is caused by changes in java.lang.String internal representation. https://bugs.openjdk.java.net/browse/JDK-8054307
Comment 1 Tomas Hurka 2016-09-30 13:41:24 UTC
Fixed in profiler-main

changeset:   300314:baa10ec0f3c3
user:        Tomas Hurka <thurka@netbeans.org>
date:        Fri Sep 30 15:38:00 2016 +0200
summary:     bugfix #268284, use HprofProxy.getString() to get value of String
Comment 2 Quality Engineering 2016-10-02 02:39:21 UTC
Integrated into 'main-silver', will be available in build *201610020002* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)

Changeset: http://hg.netbeans.org/main-silver/rev/baa10ec0f3c3
User: Tomas Hurka <thurka@netbeans.org>
Log: bugfix #268284, use HprofProxy.getString() to get value of String
Comment 3 Tomas Hurka 2016-12-02 13:31:17 UTC
Fix transplanted to release82 branch:

changeset:   313493:0cf639326ef3
branch:      release82
user:        Tomas Hurka <thurka@netbeans.org>
date:        Fri Sep 30 15:38:00 2016 +0200
files:       profiler.heapwalker/src/org/netbeans/modules/profiler/heapwalk/details/jdk/ui/Utils.java
description:
bugfix #268284, use HprofProxy.getString() to get value of String
(transplanted from baa10ec0f3c3e7e14ef093ddbc175cc051c670cf)
Comment 4 Jiri Skrivanek 2016-12-13 13:36:09 UTC
Verified in 8.2 with patch 1.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo