Bug 268278 - NullPointerException at org.netbeans.editor.ext.ToolTipSupport.ensureVisibility
NullPointerException at org.netbeans.editor.ext.ToolTipSupport.ensureVisibility
Status: VERIFIED FIXED
Product: cnd
Classification: Unclassified
Component: Debugger
Dev
All All
: P3 (vote)
: 8.2
Assigned To: Maria Tishkova
issues@cnd
EXCEPTIONS_REPORT, 82patch1-verified
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2016-09-29 21:01 UTC by tbrunhoff
Modified: 2016-12-12 09:06 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (2.23 KB, text/plain)
2016-09-29 21:01 UTC, tbrunhoff
Details

Note You need to log in before you can comment on or make changes to this bug.
Description tbrunhoff 2016-09-29 21:01:25 UTC
This bug was originally marked as duplicate of bug 190136, that is already resolved. This bug is still valid, so this seems to be another bug, but it might be related.

Build: NetBeans IDE Dev (Build 201609190002)
VM: Java HotSpot(TM) 64-Bit Server VM, 25.45-b02, Java(TM) SE Runtime Environment, 1.8.0_45-b14
OS: Linux

User Comments:
tbrunhoff: stepping in the debugger.




Stacktrace: 
java.lang.NullPointerException
   at org.netbeans.editor.ext.ToolTipSupport.ensureVisibility(ToolTipSupport.java:825)
   at org.netbeans.editor.ext.ToolTipSupport.setToolTip(ToolTipSupport.java:375)
   at org.netbeans.editor.ext.ToolTipSupport.setToolTip(ToolTipSupport.java:331)
   at org.netbeans.editor.ext.ToolTipSupport.setToolTip(ToolTipSupport.java:290)
   at org.netbeans.editor.ext.ToolTipSupport.setToolTip(ToolTipSupport.java:280)
   at org.netbeans.editor.ext.ToolTipSupport.setToolTip(ToolTipSupport.java:276)
Comment 1 tbrunhoff 2016-09-29 21:01:26 UTC
Created attachment 162278 [details]
stacktrace
Comment 2 Martin Entlicher 2016-10-03 14:54:15 UTC
This is a result of a race condition. See #190136 - the UI code needs to be called in AWT thread.
Comment 3 Maria Tishkova 2016-12-08 08:58:21 UTC
fixed on enum
changeset:   313801:e21148930fc1
branch:      release82
tag:         tip
parent:      313789:b46bfd32cc57
user:        Maria Dalmatova <mromashova@netbeans.org>
date:        Thu Dec 08 11:57:20 2016 +0300
summary:     fixed bz#268278 - NullPointerException at org.netbeans.editor.ext.ToolTipSupport.ensureVisibility
Comment 4 Quality Engineering 2016-12-10 02:59:29 UTC
Integrated into 'main-silver', will be available in build *201612100001* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)

Changeset: http://hg.netbeans.org/main-silver/rev/f1119d5d9de9
User: Maria Dalmatova <mromashova@netbeans.org>
Log: fixed bz#268278 - NullPointerException at org.netbeans.editor.ext.ToolTipSupport.ensureVisibility
(transplanted from e21148930fc1f02bb3b23d1b3118ed9ebaead855)
Comment 5 soldatov 2016-12-12 09:06:49 UTC
I can't reproduce this random exception in internal NetBeans 8,2 patch 1 build.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo