Bug 26812 - Unclear behaviour of "Start debug" button
Unclear behaviour of "Start debug" button
Status: VERIFIED WONTFIX
Product: platform
Classification: Unclassified
Component: Window System
3.x
PC Windows ME/2000
: P4 (vote)
: 4.x
Assigned To: _ tboudreau
issues@platform
: FOCUS
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2002-08-27 15:17 UTC by sva
Modified: 2008-12-22 16:00 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description sva 2002-08-27 15:17:22 UTC
Steps to reproduce:
1. Open properties window for JSP.
2. Switch to Execution tab.
3. Select "(do not debug option)" for Debugger value.
4. Close dialog and press Alt+f5 to start debugger.
5. When dialog "Incorrect configuration" will shown, press 
configure button.
6. Press "Cancel" in next dialog.

Result: "Start" debugger button is grayed as well as "Run 
to cursor". If I switch to other JSP, then switch back, 
Start button became active.

Well reproduced under WinXP & Win2K with Sun One Studio 4 
update 1, build 020822_1
Comment 1 Petr Jiricka 2002-08-28 09:43:41 UTC
Also reproducible in NetBeans dev build 20020827. 

This looks like a focus issue, assigning to core.
Comment 2 Marian Mirilovic 2002-11-13 15:31:16 UTC
changed owner Dafe -> Peter Z.
Comment 3 Peter Zavadsky 2002-12-04 15:36:17 UTC
Those actions belong to debugger. Reassigning.
Comment 4 Jan Jancura 2003-01-14 17:28:15 UTC
The bug is in core module. When user press "configure" button
ServiceTypePanel is opened and some ugly selected nodes are set. And
they are not removed when ServiceTypePanel is closed (original nodes
are not set).
Comment 5 mslama 2003-02-25 09:37:20 UTC
Probably it is necessary to check where focus is going to correctly
set selected nodes.
Comment 6 mslama 2004-04-19 15:04:25 UTC
Assigning to Tim
Comment 7 _ tboudreau 2004-05-27 20:15:28 UTC
No longer an issue in Stavbicka.
Comment 8 Marian Mirilovic 2005-07-12 10:03:06 UTC
closed


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo