Bug 268022 - No C/C++ Compilers Found window appears on adding a remote host
No C/C++ Compilers Found window appears on adding a remote host
Status: RESOLVED FIXED
Product: cnd
Classification: Unclassified
Component: Toolchain
8.2
PC Windows 7
: P2 (vote)
: 8.2
Assigned To: Alexander Simon
issues@cnd
: TEST
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2016-09-14 13:56 UTC by Alexander Pepin
Modified: 2016-09-15 10:03 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alexander Pepin 2016-09-14 13:56:28 UTC
If a user is going to use CND only for remote development and does not have appropriate compilers on the local machine or those compilers were not detected for some reason then "No C/C++ Compilers Found" window appears when a user is adding a remote development host.

Steps to reproduce:
- run CND on the machine without compilers with a fresh userdir
- switch Remote toolbar on
- call 'Manage Hosts' from the dropdown list on the remote toolbar
Result: "No C/C++ Compilers Found" window appears together with "Build Host Manager" window and remains after closing "Build Host Manager".
 Sometimes it breaks functional tests or requires a workaround.
Comment 1 Alexander Simon 2016-09-14 14:52:58 UTC
fixed, change set:
http://hg.netbeans.org/cnd-main/rev/fd9558cc88f9

Remove dialog at all.
Reasons:
- dialog outdated (does not include host info)
- host can be set up without initializing compilers
- there is no place when dialog will be appeared because tool collection initialization is "lazy" and invoked from different UI places. The dialog can led to UI problems.
Comment 2 Quality Engineering 2016-09-15 02:05:04 UTC
Integrated into 'main-silver', will be available in build *201609150002* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)

Changeset: http://hg.netbeans.org/main-silver/rev/fd9558cc88f9
User: Alexander Simon <alexvsimon@netbeans.org>
Log: fixed Bug #268022 No C/C++ Compilers Found window appears on adding a remote host
- remove dialog at all


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo