Bug 267937 - NullPointerException at org.netbeans.modules.remote.ui.NewRemoteProjectAction.performAction
NullPointerException at org.netbeans.modules.remote.ui.NewRemoteProjectAction...
Status: RESOLVED FIXED
Product: cnd
Classification: Unclassified
Component: Remote
8.1
All All
: P2 (vote)
: 8.2
Assigned To: Vladimir Kvashin
issues@cnd
EXCEPTIONS_REPORT
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2016-09-08 05:01 UTC by Exceptions Reporter
Modified: 2017-03-06 09:45 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (3.39 KB, text/plain)
2016-09-08 05:01 UTC, Exceptions Reporter
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Exceptions Reporter 2016-09-08 05:01:40 UTC
Build: NetBeans IDE 8.1 (Build 201510222201)
VM: Java HotSpot(TM) 64-Bit Server VM, 25.45-b02, Java(TM) SE Runtime Environment, 1.8.0_45-b15
OS: Windows 8

User Comments:
GUEST: C/C++ Build Hosts
> New C/C++ proyect




Stacktrace: 
java.lang.NullPointerException
   at org.netbeans.modules.remote.ui.NewRemoteProjectAction.performAction(NewRemoteProjectAction.java:82)
   at org.netbeans.modules.remote.ui.SingleHostAction.performAction(SingleHostAction.java:103)
   at org.openide.util.actions.NodeAction$DelegateAction$1.run(NodeAction.java:586)
   at org.openide.util.actions.ActionInvoker$1.run(ActionInvoker.java:95)
   at org.openide.util.actions.ActionInvoker.doPerformAction(ActionInvoker.java:116)
   at org.openide.util.actions.ActionInvoker.invokeAction(ActionInvoker.java:99)
Comment 1 Exceptions Reporter 2016-09-08 05:01:42 UTC
Created attachment 161962 [details]
stacktrace
Comment 2 Vladimir Kvashin 2016-09-08 09:28:45 UTC
This can not be reproduced. I checked dev version, pure 8.1 and 9.1 with exactly the same update as user has. I think something was broken in user directory. However sure null check should be added. Fixed in
http://hg.netbeans.org/cnd-main/rev/38d095c10863
Comment 3 Vladimir Kvashin 2016-09-08 15:41:21 UTC
(In reply to Vladimir Kvashin from comment #2)
> ... I checked dev version, pure 8.1 and 9.1 with
> exactly the same update as user has.....
That's a typo, sure I meant 8.1, not 9.1  :)
Comment 4 Quality Engineering 2016-09-09 01:53:01 UTC
Integrated into 'main-silver', will be available in build *201609090002* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)

Changeset: http://hg.netbeans.org/main-silver/rev/38d095c10863
User: Vladimir Kvashin <vkvashin@netbeans.org>
Log: fixed #267937 - NullPointerException at org.netbeans.modules.remote.ui.NewRemoteProjectAction.performAction
Comment 5 ajavier 2017-01-31 19:52:42 UTC
I realized the bug shows up when the C/C++ plugin is not installed in the IDE. However, a proper error message should be displayed to let the developer know how to fix it, instead of producing a dump of the Java stacktrace :)
Comment 6 Vladimir Kvashin 2017-03-06 09:45:10 UTC
(In reply to ajavier from comment #5)
You use 8.1 (IDE log shows: NetBeans IDE 8.1 (Build 20151231-debian-8.1). 
This bug is fixed in 8.2.
Please upgrade to 8.2 (and please allow IDE to get updates since a patch to 8.2 has been done, but this patch is not included into 8.2 distribution, only into the update center).


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo