Bug 267907 - AssertionError: scala.tools.nsc.doc.model.IndexModelFactory$$anon$1$result$2$c
AssertionError: scala.tools.nsc.doc.model.IndexModelFactory$$anon$1$result$2$c
Status: RESOLVED FIXED
Product: editor
Classification: Unclassified
Component: Parsing & Indexing
8.2
All All
: P2 (vote)
: 8.2
Assigned To: Tomas Zezula
issues@editor
EXCEPTIONS_REPORT
:
: 268160 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2016-09-06 18:58 UTC by Exceptions Reporter
Modified: 2016-09-27 06:59 UTC (History)
7 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (3.04 KB, text/plain)
2016-09-06 18:58 UTC, Exceptions Reporter
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Exceptions Reporter 2016-09-06 18:58:01 UTC
This bug was originally marked as duplicate of bug 267469, that is already resolved. This bug is still valid, so this seems to be another bug, but it might be related.

Build: NetBeans IDE Dev (Build 201609060002)
VM: Java HotSpot(TM) 64-Bit Server VM, 25.45-b02, Java(TM) SE Runtime Environment, 1.8.0_45-b14
OS: Mac OS X

User Comments:
Rahul.khandelwal: Uninstalled older dev build completely and installed the new dev build, just opened two projects.

emiddio: first startup from fresh install - new profile dir and cache dir

alexvsimon: start IDE

mps77: add jar libraries

emiddio: unknown

GUEST: AssertionError at org.netbeans.modules.java.source.usages.BinaryName.<init>

GUEST: I have clean build maven project then I got this error in a popup

terje7601: I just switched project groups and NetBeans was busy opening the projects & doing its background scanning (Java EE and HTML5 web projects)

prusinek74: First start of ide, having NB8.1 running in bckground, I got monit about importing founded setting of previous version - this error happend after that

GUEST: Starting NetBeans

emiddio: unknown

GUEST: started netbeans

mclaborn: Starting net beans (with empty cache directory)




Stacktrace: 
java.lang.AssertionError: scala.tools.nsc.doc.model.IndexModelFactory$$anon$1$result$2$c
   at org.netbeans.modules.java.source.usages.BinaryName.<init>(BinaryName.java:65)
   at org.netbeans.modules.java.source.usages.BinaryName.create(BinaryName.java:173)
   at org.netbeans.modules.java.source.usages.BinaryAnalyser.analyse(BinaryAnalyser.java:674)
   at org.netbeans.modules.java.source.usages.BinaryAnalyser.access$800(BinaryAnalyser.java:140)
   at org.netbeans.modules.java.source.usages.BinaryAnalyser$ArchiveProcessor.executeImpl(BinaryAnalyser.java:1255)
   at org.netbeans.modules.java.source.usages.BinaryAnalyser$RootProcessor.execute(BinaryAnalyser.java:1145)
Comment 1 Exceptions Reporter 2016-09-06 18:58:04 UTC
Created attachment 161929 [details]
stacktrace
Comment 2 Tomas Zezula 2016-09-12 14:47:07 UTC
Fixed jet-main 8f42334b6cf0
Comment 3 Tomas Zezula 2016-09-12 14:54:24 UTC
Increasing priority to propagate the fix into NB 8.2
Comment 4 Quality Engineering 2016-09-13 02:02:55 UTC
Integrated into 'main-silver', will be available in build *201609130002* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)

Changeset: http://hg.netbeans.org/main-silver/rev/8f42334b6cf0
User: Tomas Zezula <tzezula@netbeans.org>
Log: #267907:AssertionError: scala.tools.nsc.doc.model.IndexModelFactory$$anon$1$result$2$c
Comment 5 Tomas Zezula 2016-09-13 17:21:34 UTC
Transplanted into NB 8.2 7d1bd5f38c5d
Comment 6 Tomas Zezula 2016-09-27 06:59:13 UTC
*** Bug 268160 has been marked as a duplicate of this bug. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo