Bug 267752 - Code Completion doesn't help to type new STL variable
Code Completion doesn't help to type new STL variable
Status: VERIFIED FIXED
Product: cnd
Classification: Unclassified
Component: Code Completion
8.2
All All
: P3 (vote)
: 8.2
Assigned To: petrk
issues@cnd
82patch1-verified
:
: 268486 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2016-08-29 15:25 UTC by soldatov
Modified: 2016-12-07 13:12 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description soldatov 2016-08-29 15:25:17 UTC
How to quickly type "vector<int> v;" in editor?

Scenario:
- Create C/C++ project
- Open main.cpp file
- Type "ve" and press Ctrl+Space
===> I see:
vector<bool,class>
vector<typename _Tp,typename _Alloc=std::allocator<_Tp>>

I can't "vector<>" or "vector"
Comment 1 Vladimir Voskresensky 2016-09-01 12:47:39 UTC
I think inserted text should  be different from displayed text, so in this case just vector<bool, |> should be the result of the first choice and vector<|> will be inserted when the second is selected
Comment 2 Vladimir Kvashin 2016-10-12 15:51:19 UTC
*** Bug 268486 has been marked as a duplicate of this bug. ***
Comment 3 Vladimir Kvashin 2016-10-14 15:02:33 UTC
fixed, change sets on enum:
060fb0261b83
dc5edaa21cf9
17f1e15f5be5
6912e5834279
00542194f939
Comment 4 Quality Engineering 2016-10-20 01:58:04 UTC
Integrated into 'main-silver', will be available in build *201610200002* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)

Changeset: http://hg.netbeans.org/main-silver/rev/dfe9f7c58535
User: Vladimir Kvashin <vkvashin@netbeans.org>
Log: fixing #267752 - Code Completion doesn't help to type new STL variable
(transplanted from 060fb0261b838888d5c72cc8fc11c5ee4f505829)
Comment 5 soldatov 2016-12-07 13:12:16 UTC
Verified in internal NetBeans 8,2 patch 1 build.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo