Bug 267711 - [newcodemodel] AssertionError: LHS: must not be called for emptyKey
[newcodemodel] AssertionError: LHS: must not be called for emptyKey
Status: RESOLVED FIXED
Product: cnd
Classification: Unclassified
Component: Code Model
8.2
All All
: P2 (vote)
: 8.2
Assigned To: petrk
issues@cnd
EXCEPTIONS_REPORT
:
: 267782 267904 267905 267917 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2016-08-26 06:30 UTC by Exceptions Reporter
Modified: 2016-09-09 11:02 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (3.26 KB, text/plain)
2016-08-26 06:30 UTC, Exceptions Reporter
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Exceptions Reporter 2016-08-26 06:30:52 UTC
Build: NetBeans IDE Dev (Build 201608250002)
VM: OpenJDK 64-Bit Server VM, 25.102-b14, OpenJDK Runtime Environment, 1.8.0_102-b14
OS: Linux

User Comments:
GUEST: .




Stacktrace: 
java.lang.AssertionError: LHS: must not be called for emptyKey
   at org.llvm.adt.DenseMapInfoObject.isEqual(DenseMapInfoObject.java:69)
   at org.llvm.adt.SmallPtrSetImplBase.insert_imp(SmallPtrSetImplBase.java:283)
   at org.llvm.adt.SmallPtrSetImpl.insert(SmallPtrSetImpl.java:121)
   at org.clang.frontend.impl.InitHeaderSearchStatics.RemoveDuplicates(InitHeaderSearchStatics.java:83)
   at org.clang.frontend.impl.InitHeaderSearch.Realize(InitHeaderSearch.java:609)
   at org.clang.frontend.FrontendClangGlobals.ApplyHeaderSearchOptions(FrontendClangGlobals.java:157)
Comment 1 Exceptions Reporter 2016-08-26 06:30:53 UTC
Created attachment 161777 [details]
stacktrace
Comment 2 petrk 2016-09-02 11:18:00 UTC
*** Bug 267782 has been marked as a duplicate of this bug. ***
Comment 3 petrk 2016-09-07 15:42:00 UTC
Fixed in sputnik 19460:67bd03f4034a
Comment 4 petrk 2016-09-09 11:02:07 UTC
*** Bug 267917 has been marked as a duplicate of this bug. ***
Comment 5 petrk 2016-09-09 11:02:36 UTC
*** Bug 267905 has been marked as a duplicate of this bug. ***
Comment 6 petrk 2016-09-09 11:02:52 UTC
*** Bug 267904 has been marked as a duplicate of this bug. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo