Bug 267668 - Accuracy regression in LLVM since Aug 19.
Accuracy regression in LLVM since Aug 19.
Status: RESOLVED FIXED
Product: cnd
Classification: Unclassified
Component: Code Model
8.2
PC Solaris
: P2 (vote)
: 8.2
Assigned To: petrk
issues@cnd
: REGRESSION
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2016-08-22 07:19 UTC by Alexander Simon
Modified: 2016-09-13 11:33 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alexander Simon 2016-08-22 07:19:10 UTC
The test project LLVM has 1500+ unresolved identifiers.
Comment 1 Alexander Simon 2016-08-22 07:20:37 UTC
Aug 17 - Unresolved 10414 (0.36%)
Aug 19 - Unresolved 11988 (0.42%)
Comment 2 petrk 2016-08-23 20:48:16 UTC
Fixing: http://hg.netbeans.org/cnd-main/rev/a4d75282afce
Comment 3 Quality Engineering 2016-08-24 01:56:04 UTC
Integrated into 'main-silver', will be available in build *201608240002* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)

Changeset: http://hg.netbeans.org/main-silver/rev/a4d75282afce
User: Petr Kudryavtsev <petrk@netbeans.org>
Log: Fixing #267668 - Accuracy regression in LLVM since Aug 19.
Comment 4 Quality Engineering 2016-08-25 01:47:06 UTC
Integrated into 'main-silver', will be available in build *201608250002* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)

Changeset: http://hg.netbeans.org/main-silver/rev/b8cb2677a76f
User: Petr Kudryavtsev <petrk@netbeans.org>
Log: Fixing #267668 - Accuracy regression in LLVM since Aug 19.
-- improved resolve context in ClassifierResolverImpl
Comment 5 petrk 2016-09-13 11:33:00 UTC
Test case which remains extracted to a separate bug 267993


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo