Bug 267327 - Caret position is not restored
Caret position is not restored
Status: VERIFIED FIXED
Product: editor
Classification: Unclassified
Component: Painting & Printing
8.2
All All
: P2 (vote)
: 8.2
Assigned To: Miloslav Metelka
issues@editor
: REGRESSION, USABILITY
: 267878 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2016-07-27 05:22 UTC by Tomas Mysik
Modified: 2016-09-05 09:15 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tomas Mysik 2016-07-27 05:22:54 UTC
Sample (part of some Java file):

-------------------------------------------
        return 0;
    }

    public void testme() {
-------------------------------------------

Steps:
- put caret at the end of the first line of the sample
- press key down 3-times
- caret is at the beginning of the line but it is expected to be at "t^estme()" (or at the end of the line, it depends)

-> this is really annoying as one needs to move caret to the proper position again and again.

This worked fine in 8.1 therefore P2. Also, this issue influences usability a lot (at least this is my case). Perhaps multicaret related?

Thanks.

Product Version: NetBeans IDE Dev (Build 201607190002)
Java: 1.8.0_101; Java HotSpot(TM) 64-Bit Server VM 25.101-b13
Runtime: Java(TM) SE Runtime Environment 1.8.0_101-b13
System: Linux version 4.4.0-31-generic running on amd64; UTF-8; cs_CZ (nb)
Comment 1 Miloslav Metelka 2016-09-02 13:57:35 UTC
Fixed. Besides Up/Down actions fixing there was an error of treating magic caret positions in the multicaret infrastructure.
http://hg.netbeans.org/jet-main/rev/fade0fdfcd05
Comment 2 Quality Engineering 2016-09-04 01:57:37 UTC
Integrated into 'main-silver', will be available in build *201609040002* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)

Changeset: http://hg.netbeans.org/main-silver/rev/fade0fdfcd05
User: Miloslav Metelka <mmetelka@netbeans.org>
Log: #267327 - Caret position is not restored.
Comment 3 Miloslav Metelka 2016-09-05 08:51:11 UTC
*** Bug 267878 has been marked as a duplicate of this bug. ***
Comment 4 Tomas Mysik 2016-09-05 09:15:12 UTC
Verified, thanks a lot!

Product Version: NetBeans IDE Dev (Build 201609040002)
Java: 1.8.0_102; Java HotSpot(TM) 64-Bit Server VM 25.102-b14
Runtime: Java(TM) SE Runtime Environment 1.8.0_102-b14
System: Linux version 4.4.19-1-MANJARO running on amd64; UTF-8; cs_CZ (nb)


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo