Bug 26681 - There is not possible update DBExplerer form autoupdate.
There is not possible update DBExplerer form autoupdate.
Status: VERIFIED FIXED
Product: db
Classification: Unclassified
Component: Code
3.x
All All
: P2 (vote)
: 4.x
Assigned To: issues@db
issues@db
:
: 26686 26715 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2002-08-21 13:52 UTC by pknakal
Modified: 2006-06-05 11:04 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
Error message (5.09 KB, application/octet-stream)
2002-08-21 13:57 UTC, pknakal
Details
Exception text (4.86 KB, text/plain)
2002-08-21 14:03 UTC, pknakal
Details
Explorer after wrong installation. (10.47 KB, application/octet-stream)
2002-08-21 14:05 UTC, pknakal
Details

Note You need to log in before you can comment on or make changes to this bug.
Description pknakal 2002-08-21 13:52:47 UTC
NB dev duild ... 200208120100. Install DB Explorer
from autoupdate and during the start after update
the error dialog is throws (attached).

Then in the Explorer|Runtime tab there is wrong
name for Databases note and this node is not
expandable.

Exception is thrown to the console.
Comment 1 pknakal 2002-08-21 13:57:26 UTC
Created attachment 7159 [details]
Error message
Comment 2 pknakal 2002-08-21 14:03:47 UTC
Created attachment 7160 [details]
Exception text
Comment 3 pknakal 2002-08-21 14:05:02 UTC
Created attachment 7161 [details]
Explorer after wrong installation.
Comment 4 Radko Najman 2002-08-21 14:29:16 UTC
Fixed.
The problem was caused by classloader changes - the core module is not
loaded by system classloader anymore, but by special classloader.
ddl.jar which is loaded by system classloader references core module
which can't be found because it was loaded by different classloader.
ddl.jar has benn moved from lib/ext to modules/ext
Comment 5 Radko Najman 2002-08-22 17:42:34 UTC
*** Issue 26715 has been marked as a duplicate of this issue. ***
Comment 6 pknakal 2002-08-28 14:52:32 UTC
Verified: NB 200208280100 && DB1.6.1 from alpha autoupdate.
Comment 7 Radko Najman 2002-09-20 12:09:24 UTC
*** Issue 26686 has been marked as a duplicate of this issue. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo