Bug 26564 - Fully support Ant 1.4.1
Fully support Ant 1.4.1
Status: RESOLVED FIXED
Product: www
Classification: Unclassified
Component: Builds & Repositories
3.x
PC Linux
: P1 (vote)
: TBD
Assigned To: Michal Zlamal
nbbuild-issues@ide
:
Depends on: 26691
Blocks:
  Show dependency treegraph
 
Reported: 2002-08-16 17:57 UTC by Jesse Glick
Modified: 2003-12-11 14:13 UTC (History)
0 users

See Also:
Issue Type: TASK
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jesse Glick 2002-08-16 17:57:51 UTC
Thanks for switching the dev build system to
1.4.1. There are some things forgotten that need
to be fixed ASAP:

1. nbextra/nbbuild/lib/ant.jar and
nbextra/nbbuild/bin/* are still Ant 1.3. These
need to be changed to be 1.4.1.

2. nbbuild/www/ant-quick.html must be updated to
mention that r34 requires 1.3 but can use 1.4.1
and dev builds require 1.4.1.
Comment 1 Jesse Glick 2002-08-16 17:58:56 UTC
Don't forget nbbuild/www/ant.html which also mentions 1.3.
Comment 2 Michal Zlamal 2002-08-20 13:45:05 UTC
WWW pages was updated. Extra binaries should be on site 
after next dev night build.
Comment 3 Jesse Glick 2002-08-20 17:16:14 UTC
nbbuild/bin/ still contains launchers from Ant 1.3, plus minor patches
for NB, e.g. in nbbuild/bin/ant:

71a72,81
> # add xml parser for netbeans on classpath
> 
> if test -f $ANT_HOME/../core/release/lib/ext/xml-apis.jar ; then
>  
LOCALCLASSPATH=$LOCALCLASSPATH:$ANT_HOME/../core/release/lib/ext/xml-apis.jar
> fi
> 
> if test -f $ANT_HOME/../core/release/lib/ext/xerces.jar ; then
>  
LOCALCLASSPATH=$LOCALCLASSPATH:$ANT_HOME/../core/release/lib/ext/xerces.jar
> fi
> 

Please update this dir with scripts from Ant 1.4.1, merging in any
patches needed for use in the NB source tree: I think the only
required changes are in ant and ant.bat to add

../core/release/lib/ext/xml-apis.jar:../core/release/lib/ext/xerces.jar

to the LOCALCLASSPATH var. Try the build with the nbextra ant (and no
predefined CLASSPATH) to make sure it works.
Comment 4 Michal Zlamal 2002-08-20 17:31:24 UTC
OK, I'll do that.
Comment 5 rbalada 2002-10-02 05:38:43 UTC
The change about nbbuild/bin will not be done, because these files
have been made obsolete.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo