Bug 26513 - [60cat]Accumulate votes over dependencies
[60cat]Accumulate votes over dependencies
Status: RESOLVED INVALID
Product: obsolete
Classification: Unclassified
Component: collabnet
3.x
All All
: P3 with 14 votes (vote)
: TBD
Assigned To: support
issues@www
PCN11587 NOT-FIXED,CNSC-017102
:
Depends on:
Blocks: 27338
  Show dependency treegraph
 
Reported: 2002-08-14 17:12 UTC by _ pkuzel
Modified: 2009-11-08 02:30 UTC (History)
4 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description _ pkuzel 2002-08-14 17:12:04 UTC
Problem: I have several related issues, then I 
create an umbrela issue for them turning 
original issues to tasks and create a 
dependency. I can also mark them as 
duplicates. Unfortunatelly new umbrella issue 
has 0 votes (similarly for duplicates). 
 
Solution: votes should propagate (be derived) 
over dependecies (and duplications).
Comment 1 jcatchpoole 2002-08-15 14:50:47 UTC
While I guess (?) this will not happen for IZ, Collab pls
consider this for Scarab.
Comment 2 Unknown 2002-08-16 17:28:00 UTC
I'll look into this for Scarab.
Thanks,
Kristenb
Comment 3 Unknown 2002-09-10 23:04:14 UTC
The ColalbNet tracking number for this enhancement is PCN11587.
Comment 4 Unknown 2002-10-16 02:54:46 UTC
Product Management is looking at this enhancement and would like some
additional information on how you would like it to work. Please
consider each of the following questions and add any other details
that may come to mind.
Thanks,
Kristen

"What is the right order of propagating votes?  

If issue #2 is marked as a duplicate of issue #1 do they both have the
same # of votes, or does just issue #1 have the accumulated votes?

Do votes only accumulate for the blocked issue? For example, if issue
#3 blocks issue #4, does issue #3 accumulate any votes?  I would
actually assume that only issue #4 would accumulate issue #3's votes
and issue #3 would be 
unaffected.

What about the propagation of votes made after the dependencies are
established?  How should this work?"

Comment 5 _ mihmax 2002-10-16 08:59:48 UTC
> If issue #2 is marked as a duplicate of issue #1 do 
> they both have the same # of votes, or does just 
> issue #1 have the accumulated votes?

Actually the dup issue #2 is closed, so it's better to add votes to
issue #1 (note that the same people may vote for both issues, so the
check is needed).

> Do votes only accumulate for the blocked issue? For 
> example, if issue #3 blocks issue #4, does issue #3
> accumulate any votes?  I would actually assume that only 
> issue #4 would accumulate issue #3's votes
> and issue #3 would be unaffected.

Yes, perfectly correct.
Other example:
umbrella #1 (depends on #2),
subumbrella #2 blocks #1 (depends on #3),
issue #3 blocks #2

Then #2 will cumulate votes from #3, and 
#1 will cumulate from #2 (both #2's and #3's votes),
Comment 6 Unknown 2002-10-30 01:55:43 UTC
Hi Maxym,
Thanks for your clarification. We've passed this 
information along to Product Management and will plan to 
update the issue as soon as we have more information from 
them. Please let us know if there are any other thoughts on 
this issue or concerns about the time frame for the next 
update.
Thanks,
Kristen
Comment 7 Unknown 2002-10-30 22:06:48 UTC
Change in our Update Plan:
Our plan is to provide a status update for this issue in 2 
weeks. Please let us know if there are concerns about the 
timeframe for the next update.
Jan
Comment 8 Unknown 2002-11-02 07:44:40 UTC
Update: This is being considered for the truckee 2 release 
of SourceCast.
Action Plan: Check regularly for updates from Product 
Management on target milestone.
Next update: Within 2 weeks
Comment 9 Unknown 2002-11-20 08:15:04 UTC
Update: Clarifying that this is being considered for Scarab in Truckee
2, not IssueZilla. 
Action Plan: Check in on internal issue again the first week of December.
Next Update: By 12-6-02
Comment 10 jveres 2002-12-12 21:49:09 UTC
Update: i asked management to provide update on the status of this
request which could be in scarab

action plan: monitor internal issue for updates by management

next update: in two weeks
Comment 11 jveres 2002-12-13 16:31:55 UTC
update: the management will consider this request:'we have not
determined the features that we are planning to add to Scarab/Project
tracker in the next release.  When we do we will consider whether to
add this.  I expect we will get to that point somewhere around the end
of January.'

Action plan: keep monitoring internal issue for updates

Next update: in three weeks
Comment 12 jveres 2003-01-07 22:18:32 UTC
no update in internal issue pcn 11587. will monitor that for any change.

next update: end of January.
Comment 13 jveres 2003-01-29 21:51:48 UTC
update: I asked management again for an update on this issue

next udpate: upon reply for management
Comment 14 jveres 2003-02-06 22:48:04 UTC
update: i reminded our management that client would like to know
'date/commitment to implement' if that possible.

action plan: waiting on management's reply.
Comment 15 jveres 2003-02-13 01:25:38 UTC
update: i'd convey the management position:

'will get to the point where we have an agreed to description of the
release and  schedule for developing it sometime in April.'
Comment 16 _ mihmax 2003-04-04 11:20:18 UTC
> sometime in April

Today is 4th April,
Status?
Comment 17 Unknown 2003-04-05 04:15:24 UTC
Hi Maxym,

I asked for an engineering update on this issue.
Action 
plan:
Update this issue with an engineering response.

Time 
frame:
I will update this issue by 4/11
Comment 18 Unknown 2003-04-13 23:25:18 UTC
Hi Maxym,

I received an update saying this is still slated for t2, but I didn't
get the information that I think we are looking for. So, I pushed back
on them to update this issue with the agreed to description of the t2
release. I will update this issue by 4/20 or earlier if possible.
Eric
Comment 19 Unknown 2003-04-14 19:34:59 UTC
Hi Maxzym,

I juist got this update from engineering.

Based on when we actually get the Product Requirement Documentaion, we
aren't going to know what is
going in or out until probably mid-May now. At that point, we'll have
some "definite" items and some "maybe" items.

We might do some voting, but gathering those up across dependencies
will probably take more time
than we have available before the T2 release.

Eric
Comment 20 _ mihmax 2003-06-19 16:44:51 UTC
Eric, mid-may passed long ago...
So, is this a "definite todo" item or not?

Status, please.
Comment 21 Unknown 2003-06-19 23:12:33 UTC
There hasn't been any updates to the issue. looks like it is not going
to be in truckee2 or plan truckee2. I have pinged the product manager
on this issue to double check.
I will update the issue when I get an update.
Eric
Comment 22 Unknown 2003-06-20 16:59:02 UTC
Product management gave me the following update.
Eric

Offering voting in Project Tracker has been scoped out of T2 and will
be considered for a post-T2 release.
Comment 23 Unknown 2003-07-30 06:47:36 UTC
Update: Setting the status of this issue to Resolved, 
Fixed. The solution for this issue has a target milestone 
of "Plan- Truckee3".
Action Plan: CollabNet support will review this issue 
during the upgrade to this release to confirm its 
resolution. If there are problems with the solution we will 
reopen this issue. If the solution appears to be working, 
we will reassign the issue to the original poster, 
requesting confirmation The original poster can then set 
the status to "Closed" or "Reopened" if necessary.

Next Update: CollabNet support will review this issue 
during the staging process for the next upgrade.

-Priya.
Comment 24 jcatchpoole 2004-08-20 08:46:30 UTC
*** Issue 47233 has been marked as a duplicate of this issue. ***
Comment 25 ejrenaud 2004-09-17 16:51:19 UTC
CollabNet support - please verify which version of CEE this is
fixed in, associate version number to nickname. i.e. - Is Truckee 3
equated to version 3.0?  

Thanks,

Eric
Comment 26 Unknown 2004-09-21 20:29:43 UTC
Given the level of effort involved, this enhancement will not be 
able to make it into Danube.

Also, the requirements regarding the voting need to be fleshed out. 
CollabNet is proposing some discussions regarding this issue. I have 
updated the whiteboard accordingly.
Comment 27 Unknown 2004-10-13 16:24:40 UTC
Updated the whiteboard for release name revision.
Comment 28 padmar 2006-09-05 12:24:24 UTC
This was not implemented in IZ and there's no voting feature in Scarab.

Reopening this issue
Comment 29 Unknown 2006-11-06 11:18:27 UTC
*** Issue 53479 has been marked as a duplicate of this issue. ***
Comment 30 deeptinker 2006-11-08 21:41:56 UTC
Any chance the duplicate rollup issue could be implemented now, and the
blocking/umbrella issue be resolved separately?
Comment 31 deeptinker 2006-11-08 21:53:28 UTC
In issue 53479, it was stated that "Project Tracker" would have this vote
handling capability.  Was it incorporated in this latest change to the web site?
 If not, is  this an internal Sun effort, an open source effort, or something
else?  Is there an URL to find out more information about Project Tracker?
Comment 32 Unknown 2006-11-30 12:37:43 UTC
to crm
Comment 33 Unknown 2007-05-16 13:25:33 UTC
We are considering to provide this enhancement for IZ in one of our future
releases. Marking this issue as Resolved Later. Support will continue to track
this issue internally and review it in the corresponding release.

Regards,
Karishma
Support Operations
Comment 34 deeptinker 2007-08-06 03:05:51 UTC
Please don't close this issue without giving a URL or something to track.  It is very frustrating to have an issue with
a number of votes marked as a duplicate of some other issue, without having the votes "roll up" to the primary issue.

Can just this part be implemented without all the other concerns originally stated?

Thanks,
Travis
Comment 35 Unknown 2007-09-19 15:30:18 UTC
Note: We are not closing issues, we are marking as Resolved later with the appropriate Target Milestone in order to
assign into the correct bucket for us to review the case when the issue is fixed in the future release.

Regards,
Ramya
Support Operations
Comment 36 twolf2919 2007-10-02 13:40:32 UTC
This is ridiculous - this problem has been open since 2002 and no one is fixing it.  It
has happened to me several times that I would file an issue, people would vote for it,
and then it would get marked as a duplicate of another issue and lose all the votes.

Even worse, I recently had an important issue collect 25+ votes when it was decided that
the issue belonged into a different component.  When it was moved, again all the votes
were lost.

How can the importance/priority of an issue be ascertained, if the issue tracking
system keeps dumping all the votes?
Comment 37 mclaassen 2007-10-02 14:47:14 UTC
I have never complained about this, but have been frustrated by it.  I don't even know if issue votes really matter and
I have certainly been discouraged from voting because of this issue.  

If the Netbeans team is interested in tracking issues by votes, then it would seem appropriate that they do everything
possible to make sure this process is not frustrating.  With things like this, it often doesn't take much to discourage
people from taking action.  And once a large percentage of people don't believe in it, the whole system can become futile.

I still occasionally vote for things, but when my votes get dumped, I don't think I have ever taken the time to put my
vote back.

I am sitting here with a smile on my face anticipating that this issue will be re-categorized, and the 3 votes garnered
so far to be lost as well. ;)
Comment 38 santafen 2007-10-02 15:07:15 UTC
This is not an "enhancement" but a defect. having the system zero-out votes when a bug is marked as a duplicate, etc. is a DEFECT and should be fixed.

The fact that it has sat open for 5 years points to the fact that it will never get fixed. But it's not an "enhancement" to stop votes from being dumped. It's a 
BUG.
Comment 39 Unknown 2007-10-02 15:12:40 UTC
Hi,

We will discuss about this with our internal team and will keep you posted once we get more information on this as soon
as possible.

Thanks,
Pritha
Support Operations.
Comment 40 deeptinker 2007-10-03 12:54:43 UTC
Back in 2002 there were discussions about what to do with votes under all kinds of conditions.  Umbrella issues, etc. 
That would be an enhancement and should be its own issue.  What I (and others) want is a fix for two small defects.  

1.  If an issue is marked as a duplicate of another issue, move the votes from the initial issue to the second issue,
even if it puts someone over their "quota" for that category.

2.  If an issue is recategorized, keep the votes, even if it puts someone over their "quota" for that category.

Keeping the votes accurate IMHO is far more important than if someone is over some vote limit through no fault of their
own.  

I am marking this issue with the current netcat symbol in hopes that the increased visibility will have a positive effect.

I also realize that the title of this issue is actually one of the "enhancement" issues.  However, all other issues that
I can find about these specific bugs have eventually been marked as duplicates of this issue. 
(http://www.netbeans.org/issues/show_bug.cgi?id=47233, http://www.netbeans.org/issues/show_bug.cgi?id=72474, etc.) 

Has these defects been filed with CollabNet?  If so, can the URL be put here so we can follow the activity and status? 
If that URL is not public can that status and activity be copied into this issue?
Comment 41 Unknown 2009-01-27 11:34:57 UTC
This has been fixed in CEE 5.2 p1. Refer issue 47233 desc26.Marking as fixed
Comment 42 Marian Mirilovic 2009-11-08 02:30:46 UTC
We recently moved out from Collabnet's infrastructure


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo