Bug 26479 - Design support for semantics XML editors
Design support for semantics XML editors
Status: VERIFIED WONTFIX
Product: xml
Classification: Unclassified
Component: Tree-Edit
3.x
PC Linux
: P1 (vote)
: 4.x
Assigned To: issues@xml
issues@xml
: API, ARCH
: 28065 (view as bug list)
Depends on: 22160 15791 27204
Blocks: 26481 19603 32052
  Show dependency treegraph
 
Reported: 2002-08-13 18:39 UTC by _ pkuzel
Modified: 2007-11-09 15:15 UTC (History)
1 user (show)

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description _ pkuzel 2002-08-13 18:39:59 UTC
Users demand semantics/logical editors. They  
do not care about underlaying XML (but they are  
proud of their indentation if they text-edit  
it). 
 
It may require semantics models or declarative 
description of UI presenting generic XML 
model.
Comment 1 _ pkuzel 2002-08-13 18:44:52 UTC
ARCHing it as it may result into a framework.  
APIng it is I expect a public contract. 
  
It may depend on issue 26478.   
Comment 2 _ pkuzel 2003-03-14 21:10:38 UTC
*** Issue 28065 has been marked as a duplicate of this issue. ***
Comment 3 zikmund 2005-05-04 15:19:26 UTC
XML tree editor is not part of NetBeans since 3.5 version. No plans to bring it
back.
Comment 4 Mikhail Matveev 2007-11-09 15:15:30 UTC
Verified - done long time ago


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo