Bug 26477 - [50cat] XML Schema based code completion
[50cat] XML Schema based code completion
Status: VERIFIED FIXED
Product: xml
Classification: Unclassified
Component: Schema
6.x
PC Linux
: P1 with 19 votes (vote)
: 6.x
Assigned To: issues@xml
issues@xml
plan lines=6000
:
: 34547 36906 55821 92656 (view as bug list)
Depends on: 26841
Blocks: 32047 32049 32061 19840 26878
  Show dependency treegraph
 
Reported: 2002-08-13 17:51 UTC by _ pkuzel
Modified: 2007-09-26 17:40 UTC (History)
8 users (show)

See Also:
Issue Type: ENHANCEMENT
:


Attachments
Proposed SchemaResolver interface (2.08 KB, patch)
2003-07-10 10:00 UTC, _ pkuzel
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description _ pkuzel 2002-08-13 17:51:40 UTC
Introduce XML Schema based code completion. The 
first version must be at least namespace-aware 
and support attribute and choice element 
completion.
Comment 1 _ pkuzel 2002-08-14 16:56:49 UTC
Feature positively influences user 
productivity.  
Comment 2 _ pkuzel 2002-08-14 16:56:53 UTC
Feature positively influences user 
productivity.  
Comment 3 Milan Kuchtiak 2002-08-27 17:15:55 UTC
This feature is essential for all J2EE deployment 
descriptors(J2EE 1.4 version).

See : http://java.sun.com/xml/ns/j2ee

All these deployment descriptors are specified by XML 
schema files and we expect from XML module(s) to support 
the code-completion feature similarily as for DTDs.

The DUBLIN release is going to implement the J2EE 1.4 spec.

Comment 4 _ pkuzel 2003-06-24 11:39:02 UTC
*** Issue 34547 has been marked as a duplicate of this issue. ***
Comment 5 _ pkuzel 2003-07-10 10:00:33 UTC
Created attachment 10929 [details]
Proposed SchemaResolver interface
Comment 6 _ pkuzel 2003-07-10 10:03:15 UTC
To be able to implement this issue in vendor neutral way I started
efford to standardize dynamical XML schema location interface. If only
something like this was in SAX or JAXP.
Comment 7 _ pkuzel 2003-09-03 11:10:47 UTC
Unscheduling from my todo list. New owner is gladly welcome. Meanwhile assigning
to abstract issues@xml.netbeans.org owner.
Comment 8 Milan Kuchtiak 2004-01-20 17:01:50 UTC
*** Issue 36906 has been marked as a duplicate of this issue. ***
Comment 9 tomzi 2004-03-26 11:55:37 UTC
will schema based code compeltion be supported in 3.6 or postponed?
Comment 10 Jesse Glick 2004-10-14 23:18:19 UTC
Obviously not in 3.6!

When we make a release, QA updates target milestones for still-open
DEFECTs to be "TBD" or something, but not FEATUREs or ENHANCEMENTs
(for some reason), so developers often forget to update them.
Comment 11 Jesse Glick 2004-10-20 18:16:26 UTC
Note that this would be very helpful for editing freeform project.xml
files.
Comment 12 rsk 2005-02-12 16:57:41 UTC
Is this only supported with schemas mounted in the XML catalog? I am
trying to get autocomplete for a schema that validates fine right now,
but it isn't in the catalog and I can't get it to work at all...
(Everything validates just fine).

What are the requiretments for this to wokr? It just keeps saying
"Cannot load document grammar" when I try and autocomplete.

File is as follows:
-----------------------
<phoenix-config xmlns="http://www.kallasoft.com/xml/ns/phoenix-config"
	xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" 
	xsi:schemaLocation="http://www.kallasoft.com/xml/ns/phoenix-config	
	http://www.kallasoft.com/xml/xsd/phoenix-config_1_0.xsd" version="1.0">
<!-- CONTENT REMOVED FOR POST -->
</phoenix-config>
------------------------
Comment 13 zikmund 2005-03-03 10:08:14 UTC
*** Issue 55821 has been marked as a duplicate of this issue. ***
Comment 14 Jiri Kovalsky 2005-05-09 15:23:27 UTC
Please take this RFE into account when planning new features into next release.
Together with #22510 this is one of two top required enhancements.
Comment 15 Marek Fukala 2005-08-24 13:44:31 UTC
no time for this to 4.2
Comment 16 misterm 2005-09-29 21:26:38 UTC
Updating to see it there is any chance this can be added for 5.0. It's been 
_three years_ and _sixteen votes_ and it's something users really need.
Comment 17 Jesse Glick 2005-09-30 01:11:59 UTC
Too late for 5.0.
Comment 18 misterm 2005-09-30 15:52:22 UTC
While I understand it is too late for 5.0, is there any chance it can get 
_officially scheduled_ for NetBeans.next? It's been 3 years, it's time to get 
this solved...
Comment 19 benfy 2006-07-17 17:16:44 UTC
Any chances to see this solved?
Comment 20 Petr Jiricka 2006-07-17 18:23:29 UTC
Adding Samaresh to cc, I believe he may be able to provide some update.
Comment 21 Chris Webster 2006-07-17 18:26:05 UTC
The NetBeans enterprise pack Beta will have code completion for instance
documents based on XML Schema. If you don't want to wait for Beta you can try a
nightly build.  
Comment 22 Jindrich Sedek 2007-01-18 14:45:59 UTC
*** Issue 92656 has been marked as a duplicate of this issue. ***
Comment 23 Roman Strobl 2007-05-20 19:28:54 UTC
Isn't this feature now available in the Enterprise pack for NetBeans 5.5? It is
listed as one of the features:

http://www.netbeans.org/products/enterprise
Comment 24 Samaresh Panda 2007-05-21 07:37:22 UTC
In 5.5, it used to be part of EntPack. This feature is now available is standard
Netbeans 6.0. You can try this with a nightly build.

What lacks today is, it doesn't fetch the schema from the internet, but soon,
that will also be fixed.

Here is what works today:
- it looks for schemas in the local project
- looks for schemas in the runtime catalog, system-id should match the location
- the CC items are namespace aware
- supports schema wildcards
Comment 25 Samaresh Panda 2007-07-12 18:14:50 UTC
Just wanted to clarify few things about my last comment.

The SACC feature now allows seamless CC based on Schemas from the internet. You should try with a nightly build.
Comment 26 Mikhail Matveev 2007-09-24 15:56:54 UTC
Fixed long time ago
Comment 27 Mikhail Matveev 2007-09-24 15:57:45 UTC
Verified


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo