Bug 262637 - IllegalStateException: Problem in some module which uses Window System: Window System API is required to be called from AWT thread only, see http://core.netbeans.org/proposals/threading/
IllegalStateException: Problem in some module which uses Window System: Windo...
Status: RESOLVED FIXED
Product: contrib
Classification: Unclassified
Component: Code
8.2
All All
: P2 with 1 vote (vote)
: TBD
Assigned To: mcheung63
issues@contrib
EXCEPTIONS_REPORT
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2016-06-30 19:24 UTC by ytn01
Modified: 2017-06-04 14:51 UTC (History)
4 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (4.82 KB, text/plain)
2016-06-30 19:24 UTC, ytn01
Details

Note You need to log in before you can comment on or make changes to this bug.
Description ytn01 2016-06-30 19:24:50 UTC
Build: NetBeans IDE Dev (Build 201606290002)
VM: Java HotSpot(TM) 64-Bit Server VM, 25.92-b14, Java(TM) SE Runtime Environment, 1.8.0_92-b14
OS: Windows 10

User Comments:
ytn01: Installed Darcula look and feel, and restarted IDE to switch to it.

GUEST: every time , when I opened  netbeans, the error ccurred.




Stacktrace: 
java.lang.IllegalStateException: Problem in some module which uses Window System: Window System API is required to be called from AWT thread only, see http://core.netbeans.org/proposals/threading/
   at org.netbeans.core.windows.WindowManagerImpl.warnIfNotInEDT(WindowManagerImpl.java:1764)
   at org.netbeans.core.windows.WindowManagerImpl.topComponentToolTipChanged(WindowManagerImpl.java:1369)
   at org.openide.windows.TopComponent.setToolTipText(TopComponent.java:1068)
   at com.peter.mavenrunner.MavenRunnerTopComponent.<init>(MavenRunnerTopComponent.java:110)
   at sun.reflect.NativeConstructorAccessorImpl.newInstance0(NativeConstructorAccessorImpl.java:0)
   at sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:62)
Comment 1 ytn01 2016-06-30 19:24:53 UTC
Created attachment 160207 [details]
stacktrace
Comment 2 mcheung63 2017-03-12 08:20:21 UTC
not the LAF problem, i delete the folder /Users/peter/Library/Application Support/NetBeans/8.2/config/modules , then it back to works.

I am not sure which module has problem, i am developing my own module, may be it crashed the netbeans, but i just can't sure.

I think i will meet this problem again soon, i will try to find the root cause.

thanks
Comment 3 mcheung63 2017-03-12 11:43:38 UTC
i found out if i remove this file, netbeans can start. That xml is generated by my own plugin.

/Users/peter/Library/Application Support/NetBeans/8.2/config/Modules/com-pdk.xml

Here is the content of the file:

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE module PUBLIC "-//NetBeans//DTD Module Status 1.0//EN"
                        "http://www.netbeans.org/dtds/module-status-1_0.dtd">
<module name="com.pdk">
    <param name="autoload">false</param>
    <param name="eager">false</param>
    <param name="enabled">true</param>
    <param name="jar">/Users/peter/workspace/PeterDevelopmentKitSuite/build/cluster/modules/com-pdk.jar</param>
    <param name="reloadable">true</param>
</module>

Please help to *PREVENT* netbeans hanging at startup.
Comment 4 Exceptions Reporter 2017-05-23 17:19:20 UTC
This bug already has 20 duplicates 
see http://statistics.netbeans.org/exceptions/detail.do?id=224876
Comment 5 Geertjan Wielenga 2017-06-04 09:08:58 UTC
That file, /Users/peter/workspace/PeterDevelopmentKitSuite/build/cluster/modules/com-pdk.jar, is YOUR file, from one of your own modules.
Comment 6 mcheung63 2017-06-04 14:51:49 UTC
yes. But this bug disappear for a few months, it should be fixed by somebody.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo