Bug 26043 - Scrolling with vertical scrollbar selects text in source
Scrolling with vertical scrollbar selects text in source
Status: CLOSED WORKSFORME
Product: platform
Classification: Unclassified
Component: Window System
3.x
PC Windows XP
: P3 (vote)
: 3.x
Assigned To: _ tboudreau
issues@platform
: FOCUS
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2002-07-26 12:39 UTC by ronnychan
Modified: 2008-12-23 14:34 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description ronnychan 2002-07-26 12:39:09 UTC
Scrolling with vertical scrollbar selects text in source:
1. Click on an item in Explorer
2. Click and hold vertical scrollbar of Source Editor and 
move it around and, as misaligned as some of us are, while 
moving around have your mousecursor accidentally moving 
over a part your source text, and hey! Stupid mouse, don't 
select my text while I told you to scroll...

It would be very kind if this were to be fixed, 'cos 
otherwise my mouse would end up hanging somewhere out of 
the window sooner or later... ;) TIA

- Ronny
Comment 1 Miloslav Metelka 2002-07-29 15:47:46 UTC
Are you using jdk1.3 or jdk1.4?
Do you use SDI or MDI mode?
I've tested on 1.4 on Redhat7.1 with Gnome1.4 and the problem does not
appear there. IMHO the AWT treats whether the mouse events are sent to
the scrollbar only or whether they "leak out" to the neighbour
components too when the mouse button is held.
Comment 2 ronnychan 2002-07-30 13:38:55 UTC
I keep having the problem on my Windows XP (Build 
2600.xpclnt_qfe.010827-1803) as I work with Netbeans IDE 
3.3.2 (Build 200206050332) with Java HotSpot Client VM 
1.4.0-b92. And it happens only in MDI-mode and not in SDI-
mode.
Comment 3 Jan Lahoda 2002-07-30 15:10:08 UTC
Hi,
   so, I was trying to reproduce this problem.  I tested WinXP,
JDK1.4.0, Forte 4.0CE. I reproduced the problem. Comments:
1. The step with focusing an item in explorer seems to be necessary.
Probably the focus is not set on the right place?
2. The same behaviour occurs when using Output window or after
uninstalling the editor (therefore when using std. swing components, I
hope).
3. I was able to reproduce it on the Solaris too (just a simple test,
no editor disabling, ...).

Conslusion:
IMO, this is probably not bug in editor. The problem may be in the
NetBeans core (it may handle events incorrectly in this case), or
Java/Swing problem. I recommend to move this bug to "core/AWT&Swing".
Comment 4 ronnychan 2002-07-31 08:27:15 UTC
I don't know whether it's up to the submitter of the issue 
to move around the issue, but hereby I move this issue 
from "editor/ui" to "core/AWT&Swing"
Comment 5 David Simonek 2002-09-12 10:13:08 UTC
Jan (& Mila probably), can you put some debug prints to editor code to
see what kind of messages do you receive in mentioned case?
I don't have access to WinXP and don't know editor code at all. Core
and openide is doing nothing with messages coming from swing AFAIK, so
I expect this to be jdk/swing problem.
Yes, Jan, can you test against Swing demo or some simple swing app
using editor pane? This would help me. Thx, Dafe.
Comment 6 Marian Mirilovic 2002-11-13 15:31:51 UTC
changed owner Dafe -> Peter Z.
Comment 7 Marian Mirilovic 2002-12-06 18:19:39 UTC
reassign to Tim, new owner of AWT/Swing
Comment 8 ronnychan 2003-01-14 09:46:28 UTC
I've lately installed a later version of NetBeans and the 
problem doesn't seem to occur anymore. I'm quite happy 
now, good work, thank y'all.

Installation:
Product Version: NetBeans IDE 3.4
IDE Versioning: IDE/1 spec=2.23.1 impl=200208222340
Operating System: Windows XP version 5.1 running on x86
Java: 1.4.1_01
VM: Java HotSpot(TM) Client VM 1.4.1_01-b01
Vendor: Sun Microsystems Inc.
System Locale: nl_NL
Comment 9 Marian Mirilovic 2003-01-14 10:35:25 UTC
As described Ronny above, it works fine now, so I close this issue. 
If problem occurs again please reopen. Thanks.
Comment 10 Quality Engineering 2003-07-01 15:54:23 UTC
Resolved for 3.4.x or earlier, no new info since then -> verified.

Comment 11 Quality Engineering 2003-07-01 16:21:18 UTC
Resolved for 3.4.x or earlier, no new info since then -> closing.
Comment 12 Quality Engineering 2008-12-23 14:34:05 UTC
This issue had *1 votes* before move to platform component


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo