Bug 25996 - Cursor disappears on IDE minimize
Cursor disappears on IDE minimize
Status: VERIFIED WONTFIX
Product: platform
Classification: Unclassified
Component: Window System
3.x
PC Windows XP
: P3 (vote)
: 3.x
Assigned To: Peter Zavadsky
issues@platform
: FOCUS
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2002-07-25 00:16 UTC by JavaDan
Modified: 2008-12-23 09:31 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description JavaDan 2002-07-25 00:16:32 UTC
May be related to issue 21614 (?).  Using bld 200206050332 
and Single MDI Window settings on WinXP Pro.  

If IDE is minimized to OS taskbar, editing cursor is 
invisible upon restore of IDE window.  Cursor re-appears 
if the source file editing window is then closed and re-
opened in the IDE workspace.
Comment 1 _ ttran 2002-07-25 11:00:38 UTC
I strongly suspect that this is an AWT/Swing bug.  The blinking of the
caret is done by Swing itself by listening on component focus events.

JDK version please?
Comment 2 JavaDan 2002-07-25 21:38:19 UTC
Am using j2sdk 1.3.1_01.  Dell Dimension 8100 (1.5GHz P4 - 
256K).

Comment 3 Jaroslav Tulach 2002-07-26 07:58:19 UTC
This bug is reported in version <= 3.4dev and still not fixed. Due to that it
forbids the release candidate for 3.4 to be promoted. Are you aware of that and
are you intensively working on the fix? If not, you should consider some
corrective action.
Comment 4 David Simonek 2002-07-26 11:00:57 UTC
seems to be OS related bug, I'm not able to reproduce, tested ok on:
- jdk1.3.1_02, win2000
- jdk1.4 beta, linux

We don't have possibility to test on XP, so Dan can you test on
win2000 to confirm that this is XP related? Thx.
(lowering to P3 to indicate that it's not reproductible and don't do
major harm to the system)
Comment 5 marcodl 2002-11-05 07:48:01 UTC
This disappearing cursor bug also happens on windows 98, with Netbeans 
3.4, jdk1.3.1_04. I also found out that if you change the document and save 
it using the save-button, the cursor reappears. However, the cursor does 
not reappear when you use ctrl-s to save the document. So it seems to be a 
focus thing.
Comment 6 Marian Mirilovic 2002-11-13 15:30:24 UTC
changed owner Dafe -> Peter Z.
Comment 7 Marian Mirilovic 2002-12-06 18:19:16 UTC
reassign to Tim, new owner of AWT/Swing
Comment 8 _ tboudreau 2003-02-26 15:20:56 UTC
Reassigning to window system, which is probably where this issue can
be solved.
Comment 9 mslama 2003-02-26 15:31:48 UTC
I reassign to editor if they can add something to this. I am not able
to reproduce it on current dev build, Linux, JDK 1.4.1_01. We had
recently one issue #31087 with missing cursor in editor but not sure
if it can be connected.
Comment 10 Martin Roskanin 2003-03-11 16:05:03 UTC
I cannot reproduce it too.
But I have reproduced the similar problem in dev build from 10.3
on win2k, jdk1.3.1_03 as well as jdk1.4.1, MDI
Use maximize and restoring to previous size buttons several times. The
focus is lost after changing the window from maximized to default size.
Editor module receives focusLost event after restoring the default
size action but no focusGain event, the problem is probably somewhere
in the core.
(You can debug gain/lost focus via debug param:
-J-Dnetbeans.debug.editor.caret.focus=true)
Maybe it is connected with the problem, that Dan mentioned also.
Reassigning to core for evaluation.
Comment 11 Martin Roskanin 2003-03-11 16:17:44 UTC
I have reproduced the problem with minimizing also.
1. minimize the window
2. drag the minimized window toolbar a little bit
3. click on the toolbar, window is restored, focus is lost
Note: I couldn't reproduce the problem on jdk1.4.1
I can reproduce it only in jdk1.3.1.
Again, editor doesn't receive focusGained event.
Anyway, after click on editor area the cursor becames visible.
Comment 12 Marian Mirilovic 2003-03-12 14:43:51 UTC
Dan, first I am sorry that this issue travels from one man to another :(. 

I hope window system is (partially) responsible for focus handling.
Comment 13 Marian Mirilovic 2003-11-26 12:56:42 UTC
Because Window System v1 will not be supported from now by our team, all old
winsys issues (now "core/window system v1" issues) are going to be closed as
WONTFIX. 

Changes in API which emerged both from UI spec 
and problems with adjusting to the older API are described in the document
http://core.netbeans.org/windowsystem/changes.html.
 It shows also recommends how the client code should be adjusted to the new
window system.

If you think this issue apply also to the new winsys then change the
subcomponent (to "core/window system") and REOPEN it.
Comment 14 Marian Mirilovic 2004-02-27 14:10:54 UTC
issue doesn't apply to new window system - verified


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo