Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 258837 - [launchers] improve icons
[launchers] improve icons
Status: RESOLVED FIXED
Product: cnd
Classification: Unclassified
Component: Project
8.1
All All
: P3 (vote)
: 8.2
Assigned To: Vladimir Voskresensky
issues@cnd
:
Depends on:
Blocks: 258806
  Show dependency treegraph
 
Reported: 2016-04-14 17:31 UTC by Vladimir Voskresensky
Modified: 2016-05-05 01:53 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
icons screenshot (6.16 KB, image/png)
2016-04-18 14:56 UTC, Alexander Simon
Details
icons screenshot (6.71 KB, image/png)
2016-04-18 15:14 UTC, Alexander Simon
Details
common public (486 bytes, image/png)
2016-04-19 09:21 UTC, Vladimir Voskresensky
Details
common private (673 bytes, image/png)
2016-04-19 09:21 UTC, Vladimir Voskresensky
Details
launcher public (558 bytes, image/png)
2016-04-19 09:22 UTC, Vladimir Voskresensky
Details
launcher private (822 bytes, image/png)
2016-04-19 09:23 UTC, Vladimir Voskresensky
Details
private-marker (775 bytes, image/png)
2016-04-19 09:23 UTC, Vladimir Voskresensky
Details
common public v2 (839 bytes, image/png)
2016-04-25 12:58 UTC, Vladimir Voskresensky
Details
common private v2 (866 bytes, image/png)
2016-04-25 12:58 UTC, Vladimir Voskresensky
Details
common public v3 (ligher) (841 bytes, image/png)
2016-04-25 13:03 UTC, Vladimir Voskresensky
Details
common private v3 (lighter) (873 bytes, image/png)
2016-04-25 14:02 UTC, Vladimir Voskresensky
Details
new icons screen shot (24.29 KB, image/png)
2016-04-26 09:33 UTC, Alexander Simon
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Vladimir Voskresensky 2016-04-14 17:31:38 UTC
As shown in https://netbeans.org/bugzilla/attachment.cgi?id=159273 the current icons are not clear and difficult for dark theme.
Please, update them
I.e. use "Run Main Project" & "Run Project" icons
Comment 1 Vladimir Voskresensky 2016-04-14 21:49:00 UTC
You can use "key" from icon cnd.modelutil/src/org/netbeans/modules/cnd/modelutil/resources/types16x16/operator_static_protected.png
Comment 2 Alexander Simon 2016-04-18 14:55:08 UTC
fixed, change set:
http://hg.netbeans.org/cnd-main/rev/2c60cf062a03
Comment 3 Alexander Simon 2016-04-18 14:56:14 UTC
Created attachment 159305 [details]
icons screenshot
Comment 4 Alexander Simon 2016-04-18 15:14:39 UTC
Created attachment 159306 [details]
icons screenshot
Comment 5 Vladimir Voskresensky 2016-04-19 09:20:17 UTC
Swing-painted variants still differs from other nice icons in IDE.
I will attach proposals
Comment 6 Vladimir Voskresensky 2016-04-19 09:21:20 UTC
Created attachment 159325 [details]
common public
Comment 7 Vladimir Voskresensky 2016-04-19 09:21:39 UTC
Created attachment 159326 [details]
common private
Comment 8 Vladimir Voskresensky 2016-04-19 09:22:36 UTC
Created attachment 159327 [details]
launcher public
Comment 9 Vladimir Voskresensky 2016-04-19 09:23:00 UTC
Created attachment 159328 [details]
launcher private
Comment 10 Vladimir Voskresensky 2016-04-19 09:23:41 UTC
Created attachment 159329 [details]
private-marker
Comment 11 Vladimir Voskresensky 2016-04-25 12:58:04 UTC
Created attachment 159426 [details]
common public v2
Comment 12 Vladimir Voskresensky 2016-04-25 12:58:32 UTC
Created attachment 159427 [details]
common private v2
Comment 13 Vladimir Voskresensky 2016-04-25 13:03:52 UTC
Created attachment 159428 [details]
common public v3 (ligher)
Comment 14 Vladimir Voskresensky 2016-04-25 14:02:09 UTC
Created attachment 159429 [details]
common private v3 (lighter)
Comment 15 Quality Engineering 2016-04-25 19:56:07 UTC
Integrated into 'main-silver', will be available in build *201604251813* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)

Changeset: http://hg.netbeans.org/main-silver/rev/2c60cf062a03
User: Alexander Simon <alexvsimon@netbeans.org>
Log: fixed Bug #258837 [launchers] improve icons
Comment 16 Vladimir Voskresensky 2016-04-25 21:28:23 UTC
http://hg.netbeans.org/cnd-main/rev/cc119176b226
Comment 17 Quality Engineering 2016-04-26 01:47:39 UTC
Integrated into 'main-silver', will be available in build *201604260002* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)

Changeset: http://hg.netbeans.org/main-silver/rev/2ea05fa97ed1
User: Alexander Simon <alexvsimon@netbeans.org>
Log: fixing Bug #258837 [launchers] improve icons
- fix color of hidden launcher (and fix the same bug in other html display names)
Comment 18 Alexander Simon 2016-04-26 07:26:03 UTC
Common and launcher icons hardly differ in dark color scheme.
Comment 19 Alexander Simon 2016-04-26 07:30:26 UTC
The fix cc119176b226 broke display name of common propertied.
Hide flag is not consistent with display name.
Comment 20 Alexander Simon 2016-04-26 07:34:49 UTC
If you take "Run" icon for default color scheme, also take "Run" icon for dark color scheme.
Comment 21 Vladimir Voskresensky 2016-04-26 07:35:52 UTC
This is by design. Thanks for your comments
Comment 22 Vladimir Voskresensky 2016-04-26 08:00:27 UTC
(In reply to Alexander Simon from comment #20)
> If you take "Run" icon for default color scheme, also take "Run" icon for
> dark color scheme.
It is implemented exactly this way
Comment 23 Vladimir Voskresensky 2016-04-26 08:03:29 UTC
(In reply to Alexander Simon from comment #19)
> The fix cc119176b226 broke display name of common propertied.
> Hide flag is not consistent with display name.
http://hg.netbeans.org/cnd-main/rev/276c6bb94641
Comment 24 Vladimir Voskresensky 2016-04-26 08:03:50 UTC
(In reply to Alexander Simon from comment #18)
> Common and launcher icons hardly differ in dark color scheme.
By design they are the same
Comment 25 Vladimir Voskresensky 2016-04-26 08:33:51 UTC
(In reply to Vladimir Voskresensky from comment #22)
> (In reply to Alexander Simon from comment #20)
> > If you take "Run" icon for default color scheme, also take "Run" icon for
> > dark color scheme.
> It is implemented exactly this way
I took "Run" icon from toolbar's dark scheme.
 http://hg.netbeans.org/cnd-main/rev/28dbd4291bd5
- use the same base icon as ProjectUI's RunProject icon + lighter common

The visual difference (no lightning border) is due to the different background used by main toobar and list view in launchers dialog.
Comment 26 Alexander Simon 2016-04-26 09:24:07 UTC
(In reply to Vladimir Voskresensky from comment #25)
> (In reply to Vladimir Voskresensky from comment #22)
> > (In reply to Alexander Simon from comment #20)
> > > If you take "Run" icon for default color scheme, also take "Run" icon for
> > > dark color scheme.
> > It is implemented exactly this way
> I took "Run" icon from toolbar's dark scheme.
>  http://hg.netbeans.org/cnd-main/rev/28dbd4291bd5
> - use the same base icon as ProjectUI's RunProject icon + lighter common
> 
> The visual difference (no lightning border) is due to the different
> background used by main toobar and list view in launchers dialog.

fixed in change set:
http://hg.netbeans.org/cnd-main/rev/eea2fe481d7a
Comment 27 Alexander Simon 2016-04-26 09:33:32 UTC
Created attachment 159436 [details]
new icons screen shot
Comment 28 Quality Engineering 2016-04-26 15:27:58 UTC
Integrated into 'main-silver', will be available in build *201604261340* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)

Changeset: http://hg.netbeans.org/main-silver/rev/cc119176b226
User: Vladimir Voskresensky <vv159170@netbeans.org>
Log: fixed #258837 - [launchers] improve icons
Comment 29 Quality Engineering 2016-04-27 02:25:52 UTC
Integrated into 'main-silver', will be available in build *201604270002* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)

Changeset: http://hg.netbeans.org/main-silver/rev/28dbd4291bd5
User: Vladimir Voskresensky <vv159170@netbeans.org>
Log: fixed #258837 - [launchers] improve icons
- use the same base icon as ProjectUI's RunProject icon + lighter common
Comment 30 Quality Engineering 2016-05-05 01:53:16 UTC
Integrated into 'main-silver', will be available in build *201605050002* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)

Changeset: http://hg.netbeans.org/main-silver/rev/4618f0fbfe3e
User: Alexander Simon <alexvsimon@netbeans.org>
Log: fixing Bug #258837 [launchers] improve icons
- write Unix style LF in meta-data files


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo