Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 258764 - API for sticky windows
API for sticky windows
Status: RESOLVED FIXED
Product: editor
Classification: Unclassified
Component: Painting & Printing
8.2
All All
: P1 (vote)
: 8.2
Assigned To: Ralph Ruijs
issues@editor
: API, API_REVIEW_FAST
: 228015 (view as bug list)
Depends on: 267807
Blocks: 215073
  Show dependency treegraph
 
Reported: 2016-04-11 06:42 UTC by Ralph Ruijs
Modified: 2016-09-28 16:28 UTC (History)
5 users (show)

See Also:
Issue Type: ENHANCEMENT
:


Attachments
Proposed patch (11.34 KB, patch)
2016-04-11 06:47 UTC, Ralph Ruijs
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Ralph Ruijs 2016-04-11 06:42:33 UTC
Support for Sticky Windows in the editor. JComponents can be added to a layer on top of the editor. Components will update their vertical position on editor changes.
Comment 1 Ralph Ruijs 2016-04-11 06:47:44 UTC
Created attachment 159197 [details]
Proposed patch
Comment 2 Ralph Ruijs 2016-04-11 06:50:20 UTC
Please review the proposed api change.
The code is on debugger_pin_watch branch in jet-main repository.

Thanks!
Comment 3 Miloslav Metelka 2016-04-14 09:50:12 UTC
Ralph, apologies for delay.

MM01) Since the editor.lib should be abandoned in the future I would appreciate if all the new editor apis could be placed in editor.lib2. It may be a bit tricky in this case but it should be doable since there's an implementation dependency of editor.lib on editor.lib2 so some necessary "bridges" could be added.

MM02) If there's no reason to extend the StickyWindowSupport class let's make it final. The EditorUI.getStickyWindowSupport() could IMHO become StickyWindowSupport.get(JTextComponent).

MM03) Although it's a mostly visual feature maybe some basic test could be added for the added methods?

I did not read the debugger part of the change yet.
Thanks.
Mila
Comment 4 Ralph Ruijs 2016-04-18 09:31:35 UTC
jet-main#9b0af5705974

MM01: moved to editor.lib2
MM02: thanks for the catch, updated

MM03: the methods forward everything to swing, even the convertPoint method.
Comment 5 Martin Entlicher 2016-04-18 12:50:59 UTC
If there are no further objections, I'm going to merge the branch into trunk this evening CEST.
Comment 6 Martin Entlicher 2016-04-18 23:16:06 UTC
The debugger_pin_watch branch is merged into trunk:
http://hg.netbeans.org/jet-main/rev/407d58493c75
Comment 7 Martin Entlicher 2016-04-18 23:17:59 UTC
*** Bug 228015 has been marked as a duplicate of this bug. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo