Bug 258710 - Netbeans IDE 8.1 cannot support ECMA2016 syntax yet.
Netbeans IDE 8.1 cannot support ECMA2016 syntax yet.
Status: RESOLVED DUPLICATE of bug 242387
Product: ide
Classification: Unclassified
Component: Code
8.1
Macintosh Mac OS X
: P1 (vote)
: TBD
Assigned To: issues@ide
issues@ide
Netbeans IDE 8.1 failes to support ja...
: PLATFORM
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2016-04-07 15:45 UTC by raliclo
Modified: 2016-04-07 16:10 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
IDE log (178.17 KB, text/plain)
2016-04-07 15:45 UTC, raliclo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description raliclo 2016-04-07 15:45:38 UTC
Product Version = NetBeans IDE 8.1 (Build 201510222201)
Operating System = Mac OS X version 10.11.4 running on x86_64
Java; VM; Vendor = 1.8.0_65
Runtime = Java HotSpot(TM) 64-Bit Server VM 25.65-b01

Reproducibility: Happens every time

STEPS:
Keyword 'let' cannot be recognized by Netbeans IDE.


ACTUAL:
 It happends every time , every js file.

EXPECTED:
 Please help fix this issue so that all developers can keep use IDE as javascript IDE.
 Otherwise, developers will have to switch other IDEs, such as Github's Atom to write javascript that use  ECMA2016 concepts.
 This is a serious issue or feature that shall be considered ASAP.
Comment 1 raliclo 2016-04-07 15:45:47 UTC
Created attachment 159151 [details]
IDE log
Comment 2 Jiri Kovalsky 2016-04-07 16:10:02 UTC
Thanks for your report.

*** This bug has been marked as a duplicate of bug 242387 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo