Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 258012 - Enable commit hooks
Enable commit hooks
Status: CLOSED DUPLICATE of bug 250776
Product: versioncontrol
Classification: Unclassified
Component: Git
8.2
PC Windows 8.1
: P3 with 2 votes (vote)
: TBD
Assigned To: Ondrej Vrabec
issues@versioncontrol
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-16 11:54 UTC by cezariusz
Modified: 2018-10-25 15:35 UTC (History)
2 users (show)

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description cezariusz 2016-02-16 11:54:01 UTC
Product Version: NetBeans IDE Dev (Build 201602080002)
Java: 1.8.0_60; Java HotSpot(TM) 64-Bit Server VM 25.60-b23
Runtime: Java(TM) SE Runtime Environment 1.8.0_60-b27
System: Windows 8.1 version 6.3 running on amd64; Cp1250; pl_PL (nb)

Git hooks doesn't work when invoking an action from NetBeans (for example commit). They work for example in IntelliJ IDEA.
Comment 1 ChrisLE 2017-03-13 08:48:04 UTC
Commit hooks are very needed, because you can commit from the IDE but it will completely ignore the hooks. If you run the tests for example, before you commit, then the commit should break if you have broken tests.
Comment 3 bondolo 2017-03-16 18:32:18 UTC
There are a variety of git extensions such as Gerrit that rely upon hooks. Please consider reprioritizing this effort.
Comment 4 bondolo 2017-03-16 18:34:43 UTC

*** This bug has been marked as a duplicate of bug 250776 ***
Comment 5 ChrisLE 2018-10-25 15:35:32 UTC
I will close it, because it will handled now at the JIRA board: https://issues.apache.org/jira/browse/NETBEANS-775. Please discuss it there for further information.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo