Bug 25702 - URL not set properly on solaris for JSP with embedded spaces in name
URL not set properly on solaris for JSP with embedded spaces in name
Status: CLOSED FIXED
Product: javaee
Classification: Unclassified
Component: Code
-S1S-
Sun Solaris
: P3 (vote)
: -S1S-
Assigned To: Petr Jiricka
issues@javaee
: SPACE_IN_PATH
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2002-07-16 20:01 UTC by Sakthivel Gopal
Modified: 2003-07-02 08:27 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Sakthivel Gopal 2002-07-16 20:01:36 UTC
IDE BUild 020715 Sierra on Solaris 9

1. Created a web module and a JSP with embedded
spaces in name like "Test JSP 123"
2. Chose "Execute Force load" on this JSP
3. The Forked browser had the URL set as
"http://localhost:8081/Test"
-- This probelm is visible on Solaris only (with
Netscape 4.7x/6.x))
Whereas on windoes the URL was set correct as
"http://localhost:8081/Test%20JSP%20123.jsp"
-sakthi
Comment 1 _ rkubacki 2002-07-18 17:24:49 UTC
Sakthi, is there anything interesting in ide.log?

BTW: what kind of browser didi you use on Win? 
Comment 2 Sakthivel Gopal 2002-07-18 18:41:37 UTC
Radim,
This behaviour is visible on Solaris 9.
On windows, it is working correctly.
This was seen with Netscape 4.79
This didn't generate any message in the log.
-sakthi
Comment 3 Marek Grummich 2002-07-22 12:04:42 UTC
Set target milestone to TBD
Comment 4 Marek Grummich 2002-07-22 12:11:03 UTC
Set target milestone to TBD
Comment 5 Alexei Mokeev 2002-07-23 11:44:43 UTC
Well reproduced for me under W2K.
Netscape 4.78 and 07/22 sierra.

Browser opened with url "http://localhost:8081/folder with space/some jsp.jsp",
and in page shown: "Apache Tomcat/4.0.1 - HTTP Status 404 - /folder"

With IE5.5 all work fine and url is: http://localhost:8081/folder%20with%20space/some%20jsp.jsp
Comment 6 _ rkubacki 2002-07-23 12:29:37 UTC
Probably we can fix in WebExecUtil or before methods from this class
are invoked.
Comment 7 Petr Jiricka 2002-07-29 14:19:07 UTC
Fixed in both sierra branch and trunk.

The fix is to URL-encode the URL before sending it to the 
browser.
Comment 8 Jason Rush 2002-07-30 23:05:55 UTC
Verified in Sierra build 020729_ee.
Comment 9 Quality Engineering 2003-07-02 08:27:36 UTC
Resolved for 3.4.x or earlier, no new info since then -> closing.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo