Bug 256966 - NullPointerException at com.sun.tools.javac.comp.Check.checkImportedPackagesObservable
NullPointerException at com.sun.tools.javac.comp.Check.checkImportedPackagesO...
Status: RESOLVED FIXED
Product: java
Classification: Unclassified
Component: Compiler
8.2
All All
: P1 (vote)
: Dev
Assigned To: Dusan Balek
issues@java
EXCEPTIONS_REPORT
:
: 270097 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-03 21:44 UTC by muellermi
Modified: 2017-09-24 02:38 UTC (History)
12 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (9.34 KB, text/plain)
2015-12-03 21:45 UTC, muellermi
Details
stacktrace (8.60 KB, text/plain)
2015-12-03 21:47 UTC, muellermi
Details
stacktrace (9.34 KB, text/plain)
2015-12-27 16:19 UTC, Jiri Kovalsky
Details
stacktrace (9.15 KB, text/plain)
2016-05-02 12:03 UTC, Exceptions Reporter
Details
stacktrace (2.24 KB, text/plain)
2016-05-02 12:09 UTC, Exceptions Reporter
Details
stacktrace (5.19 KB, text/plain)
2016-07-06 07:15 UTC, IrianR
Details

Note You need to log in before you can comment on or make changes to this bug.
Description muellermi 2015-12-03 21:44:59 UTC
Build: NetBeans IDE Dev (Build 201512010002)
VM: Java HotSpot(TM) 64-Bit Server VM, 1.9.0-ea-b93, Java(TM) SE Runtime Environment, 1.9.0-ea-b93
OS: Windows 8.1

User Comments:
muellermi: opening file in editor




Stacktrace: 
java.lang.NullPointerException
   at com.sun.tools.javac.comp.Check.checkImportedPackagesObservable(Check.java:3668)
   at com.sun.tools.javac.comp.TypeEnter.finishImports(TypeEnter.java:235)
   at com.sun.tools.javac.comp.TypeEnter.complete(TypeEnter.java:220)
   at com.sun.tools.javac.code.Symbol.complete(Symbol.java:582)
   at com.sun.tools.javac.code.Symbol$ClassSymbol.complete(Symbol.java:1097)
   at com.sun.tools.javac.comp.Enter.complete(Enter.java:721)
Comment 1 muellermi 2015-12-03 21:45:01 UTC
Created attachment 157654 [details]
stacktrace
Comment 2 muellermi 2015-12-03 21:47:41 UTC
Created attachment 157655 [details]
stacktrace

update mercurial project
Comment 3 Jiri Kovalsky 2015-12-27 16:19:58 UTC
Created attachment 157933 [details]
stacktrace

Just opened my Rachota 2.3 project and opened AboutDialog.java file in Editor.
Comment 4 Exceptions Reporter 2016-03-17 20:44:28 UTC
This bug already has 5 duplicates 
see http://statistics.netbeans.org/exceptions/detail.do?id=221497
Comment 5 Exceptions Reporter 2016-05-02 12:03:11 UTC
Created attachment 159507 [details]
stacktrace

Importing a Java8 project (with little AWT in it) and everything turned red
Comment 6 Exceptions Reporter 2016-05-02 12:09:11 UTC
Created attachment 159508 [details]
stacktrace

Still navingating trhough project (which is already supposedly not buildable, but it builds and run a project using Java9)
Comment 7 IrianR 2016-07-06 07:15:46 UTC
Created attachment 160276 [details]
stacktrace

Opening a very old project.

When I say very old it meand JDK 1.3 that might well be the root cause of the problem.
Comment 8 Exceptions Reporter 2016-10-05 21:43:24 UTC
This bug already has 10 duplicates 
see http://statistics.netbeans.org/exceptions/detail.do?id=221497
Comment 9 Exceptions Reporter 2017-09-15 06:29:32 UTC
This bug already has 50 duplicates 
see http://statistics.netbeans.org/exceptions/detail.do?id=221497
Comment 10 Dusan Balek 2017-09-22 10:45:43 UTC
*** Bug 270097 has been marked as a duplicate of this bug. ***
Comment 12 Quality Engineering 2017-09-24 02:38:29 UTC
Integrated into 'main-silver', will be available in build *201709240002* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)

Changeset: http://hg.netbeans.org/main-silver/rev/19d2c69d935e
User: Dusan Balek <dbalek@netbeans.org>
Log: Issues #256966, #270308, and #271310 fixed.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo