Bug 256534 - NullPointerException at org.netbeans.modules.cnd.debugger.common2.debugger.breakpoints.BreakpointManager$BreakpointJobs.get
NullPointerException at org.netbeans.modules.cnd.debugger.common2.debugger.br...
Status: VERIFIED FIXED
Product: cnd
Classification: Unclassified
Component: Debugger
8.1
All All
: P3 (vote)
: 8.2
Assigned To: Maria Tishkova
issues@cnd
EXCEPTIONS_REPORT, 82patch1-verified
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-12 05:22 UTC by Exceptions Reporter
Modified: 2016-12-12 09:04 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (2.61 KB, text/plain)
2015-11-12 05:22 UTC, Exceptions Reporter
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Exceptions Reporter 2015-11-12 05:22:43 UTC
Build: Oracle Solaris Studio Dodona (2015/08/21 e9be15fa1fd9)
VM: OpenJDK 64-Bit Server VM, 24.79-b02, OpenJDK Runtime Environment, 1.7.0_79-b14
OS: Linux

User Comments:
GUEST: debugging

GUEST: debugging




Stacktrace: 
java.lang.NullPointerException
   at org.netbeans.modules.cnd.debugger.common2.debugger.breakpoints.BreakpointManager$BreakpointJobs.get(BreakpointManager.java:337)
   at org.netbeans.modules.cnd.debugger.common2.debugger.breakpoints.BreakpointManager.getBreakpointJob(BreakpointManager.java:362)
   at org.netbeans.modules.cnd.debugger.common2.debugger.breakpoints.BreakpointManager.noteBreakpointError(BreakpointManager.java:480)
   at org.netbeans.modules.cnd.debugger.common2.debugger.NativeDebuggerManager.error(NativeDebuggerManager.java:1646)
   at org.netbeans.modules.cnd.debugger.dbx.Dbx.error(Dbx.java:1369)
   at com.sun.tools.swdev.glue.dbx.GPDbxSurrogate.decode_error(GPDbxSurrogate.java:1415)
Comment 1 Exceptions Reporter 2015-11-12 05:22:45 UTC
Created attachment 157298 [details]
stacktrace
Comment 2 Maria Tishkova 2016-12-01 07:56:33 UTC
there was an assert check which is hiding NPE in release, so need check for null

changeset:   313516:29cb9e7dcd4a
branch:      release82
tag:         tip
parent:      313513:643fea0f25d3
user:        Maria Dalmatova <mromashova@netbeans.org>
date:        Thu Dec 01 10:55:35 2016 +0300
summary:     fixed bz#256534 - NullPointerException at org.netbeans.modules.cnd.debugger.common2.debugger.breakpoints.BreakpointManager$BreakpointJobs.ge
Comment 3 Quality Engineering 2016-12-03 03:04:03 UTC
Integrated into 'main-silver', will be available in build *201612030001* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)

Changeset: http://hg.netbeans.org/main-silver/rev/f743215903d0
User: Maria Dalmatova <mromashova@netbeans.org>
Log: fixed bz#256534 - NullPointerException at org.netbeans.modules.cnd.debugger.common2.debugger.breakpoints.BreakpointManager$BreakpointJobs.ge
(transplanted from 29cb9e7dcd4a36f1f9121766832026b951c32cf0)
Comment 4 soldatov 2016-12-12 09:04:13 UTC
I can't reproduce this random exception in internal NetBeans 8,2 patch 1 build.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo