Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 256167 - IllegalStateException: Module org.netbeans.api.progress/1 is already enabled
IllegalStateException: Module org.netbeans.api.progress/1 is already enabled
Status: RESOLVED DUPLICATE of bug 247884
Product: platform
Classification: Unclassified
Component: Module System
8.1
All All
: P3 (vote)
: TBD
Assigned To: Tomas Hurka
issues@platform
EXCEPTIONS_REPORT
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-25 13:03 UTC by Exceptions Reporter
Modified: 2015-10-29 10:37 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (6.69 KB, text/plain)
2015-10-25 13:04 UTC, Exceptions Reporter
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Exceptions Reporter 2015-10-25 13:03:59 UTC
This bug was originally marked as duplicate of bug 247884, that is already resolved. This bug is still valid, so this seems to be another bug, but it might be related.

Build: NetBeans IDE 8.1 Beta (Build 201508041349)
VM: Java HotSpot(TM) 64-Bit Server VM, 25.60-b23, Java(TM) SE Runtime Environment, 1.8.0_60-b27
OS: Windows 10

User Comments:
GUEST: Trying to install OpenShift extension




Stacktrace: 
java.lang.IllegalStateException: Module org.netbeans.api.progress/1 is already enabled
   at org.netbeans.ModuleManager.attachModuleFragment(ModuleManager.java:1019)
   at org.netbeans.ModuleManager.maybeAddToEnableList(ModuleManager.java:1585)
   at org.netbeans.ModuleManager.maybeAddToEnableList(ModuleManager.java:1595)
   at org.netbeans.ModuleManager.simulateEnable(ModuleManager.java:1534)
   at org.netbeans.ModuleManager.simulateEnable(ModuleManager.java:1508)
   at org.netbeans.modules.autoupdate.services.OperationValidator$EnableValidator.getModulesToEnable(OperationValidator.java:363)
Comment 1 Exceptions Reporter 2015-10-25 13:04:01 UTC
Created attachment 156968 [details]
stacktrace
Comment 2 Tomas Hurka 2015-10-29 10:37:13 UTC

*** This bug has been marked as a duplicate of bug 247884 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo