Bug 25538 - There is not possible to execute rmid_wrapper.sh script
There is not possible to execute rmid_wrapper.sh script
Status: CLOSED INVALID
Product: obsolete
Classification: Unclassified
Component: rmi
-S1S-
Sun All
: P1 (vote)
: 3.x
Assigned To: issues@obsolete
issues@obsolete
: SPACE_IN_PATH
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2002-07-11 15:33 UTC by pknakal
Modified: 2003-07-01 14:26 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
Diff file (20.40 KB, patch)
2002-07-18 15:53 UTC, Tomas Zezula
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description pknakal 2002-07-11 15:33:17 UTC
When the IDE is installed in the directory with
space the rmid_wrapper ends with an error.
Installed in:
/space/pknakal/NetBeans/netbeans\ 0711/
rmid_wrapper.sh result:
/space/pknakal/NetBeans/netbeans: does not exist
Comment 1 Tomas Zezula 2002-07-18 14:48:34 UTC
Fixed by changing RMIDWrapperImpl to start RMID with log option in
case when ${IDEHOME} contains white space.
Fixed UNIX script to use eval and quoted ${IDEHOME}
Fixed Windows native launcher to use Win32 CreateProcess rather than
depricated spawn call.
Comment 2 Tomas Zezula 2002-07-18 15:53:05 UTC
Created attachment 6779 [details]
Diff file
Comment 3 Dusan Balek 2002-07-18 16:45:33 UTC
Reviewed - the patch looks OK.
Comment 4 pknakal 2002-07-24 15:01:52 UTC
Verified.
Comment 5 pknakal 2002-07-25 14:59:11 UTC
Please propagate the fix to siera branch. Thanks. Pat
Comment 6 Tomas Zezula 2002-07-31 09:46:04 UTC
Already fixed in CVS HEAD, NetBeans 3.4 and Sierra.
Comment 7 Quality Engineering 2003-07-01 14:25:00 UTC
Resolved for 3.4.x or earlier, no new info since then -> closing.
Comment 8 Quality Engineering 2003-07-01 14:26:45 UTC
Resolved for 3.4.x or earlier, no new info since then -> closing.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo