Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 254828 - OutOfMemoryError: GC overhead limit exceeded
OutOfMemoryError: GC overhead limit exceeded
Status: RESOLVED DUPLICATE of bug 249165
Product: web
Classification: Unclassified
Component: HTML Project
8.0
All All
: P3 (vote)
: 8.1
Assigned To: Tomas Mysik
issues@web
EXCEPTIONS_REPORT
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-28 17:15 UTC by An3benavi2
Modified: 2015-08-31 05:14 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (1.51 KB, text/plain)
2015-08-28 17:15 UTC, An3benavi2
Details

Note You need to log in before you can comment on or make changes to this bug.
Description An3benavi2 2015-08-28 17:15:09 UTC
Build: NetBeans IDE 8.0.2 (Build 201411181905)
VM: Java HotSpot(TM) 64-Bit Server VM, 25.5-b02, Java(TM) SE Runtime Environment, 1.8.0_05-b13
OS: Windows 7

User Comments:
GUEST: Updating javascript library

GUEST: .

GUEST: The program freezed.

GUEST: non

GUEST: Javascript libraries updated. When I wanted to select a library, in the Cordovca project wizard, the list says "loading", but never finishes. No library is shown (Angular, JQuery etc., nothing).

An3benavi2: I upgraded javascritpt's libraries (CDNJS) and now get this error.
Then modify the parameter -J-Xmx1024m but still does not work


java.lang.OutOfMemoryError: GC overhead limit exceeded
	at java.util.Arrays.copyOfRange(Arrays.java:3658)
	at java.lang.String.<init>(String.java:201)
	at java.lang.StringBuilder.toString(StringBuilder.java:407)
	at org.netbeans.modules.web.clientproject.libraries.CDNJSLibrariesProvider.getFiles(CDNJSLibrariesProvider.java:378)
	at org.netbeans.modules.web.clientproject.libraries.CDNJSLibrariesProvider.createLibrary(CDNJSLibrariesProvider.java:366)
	at org.netbeans.modules.web.clientproject.libraries.CDNJSLibrariesProvider.readLibraries(CDNJSLibrariesProvider.java:220)
	at org.netbeans.modules.web.clientproject.libraries.CDNJSLibrariesProvider.getLibraries(CDNJSLibrariesProvider.java:118)
	at org.netbeans.modules.web.clientproject.api.WebClientLibraryManager.addLibraries(WebClientLibraryManager.java:311)
	at org.netbeans.modules.web.clientproject.api.WebCli

GUEST: Problemas atualizando a biblioteca de JavaScripts

GUEST: ?




Stacktrace: 
java.lang.OutOfMemoryError: GC overhead limit exceeded
   at java.util.Arrays.copyOfRange(Arrays.java:3658)
   at java.lang.String.<init>(String.java:201)
   at java.lang.StringBuilder.toString(StringBuilder.java:407)
   at java.net.URLStreamHandler.parseURL(URLStreamHandler.java:253)
   at org.netbeans.JarClassLoader$JarURLStreamHandler.parseURL(JarClassLoader.java:1027)
   at java.net.URL.<init>(URL.java:615)
Comment 1 An3benavi2 2015-08-28 17:15:12 UTC
Created attachment 155726 [details]
stacktrace
Comment 2 Tomas Mysik 2015-08-31 05:14:36 UTC

*** This bug has been marked as a duplicate of bug 249165 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo