Bug 254223 - IllegalStateException: Should not acquire Children.MUTEX while holding ProjectManager.mutex()
IllegalStateException: Should not acquire Children.MUTEX while holding Projec...
Status: RESOLVED FIXED
Product: third-party
Classification: Unclassified
Component: -- Other --
8.1
All All
: P3 (vote)
: TBD
Assigned To: breebo
issues@third-party
EXCEPTIONS_REPORT
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-09 15:08 UTC by lehel
Modified: 2017-04-10 13:02 UTC (History)
8 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (4.34 KB, text/plain)
2015-08-09 15:08 UTC, lehel
Details
stacktrace (4.25 KB, text/plain)
2016-02-15 01:40 UTC, Lou Dasaro
Details
stacktrace (5.25 KB, text/plain)
2017-04-09 12:58 UTC, brettryan
Details

Note You need to log in before you can comment on or make changes to this bug.
Description lehel 2015-08-09 15:08:43 UTC
This issue was reported manually by lehel.
It already has 1 duplicates 


Build: NetBeans IDE 8.1 Beta (Build 201508041349)
VM: Java HotSpot(TM) 64-Bit Server VM, 25.20-b23, Java(TM) SE Runtime Environment, 1.8.0_20-b26
OS: Windows 8

User Comments:
lehel: 1. Create a JavaFx project from existing sources: 'DisplayShelf' 
2. Select 'Run as WebStart' from Netbeans toolbar menu




Stacktrace: 
java.lang.IllegalStateException: Should not acquire Children.MUTEX while holding ProjectManager.mutex()
   at org.openide.nodes.Children$ProjectManagerDeadlockDetector.execute(Children.java:1935)
   at org.netbeans.modules.openide.util.DefaultMutexImplementation.postRequest(DefaultMutexImplementation.java:1022)
   at org.netbeans.modules.openide.util.DefaultMutexImplementation.postRequest(DefaultMutexImplementation.java:985)
   at org.netbeans.modules.openide.util.DefaultMutexImplementation.postWriteRequest(DefaultMutexImplementation.java:356)
   at org.openide.util.Mutex.postWriteRequest(Mutex.java:388)
   at org.openide.nodes.Children$Keys.applyKeys(Children.java:1582)
Comment 1 lehel 2015-08-09 15:08:45 UTC
Created attachment 155232 [details]
stacktrace
Comment 2 Antonin Nebuzelsky 2015-08-10 09:50:22 UTC
de.nigjo.kll.important.nodes.ImportantFileChildFactory$ProjectFileListener
Comment 3 Exceptions Reporter 2015-09-21 22:48:16 UTC
This bug already has 5 duplicates 
see http://statistics.netbeans.org/exceptions/detail.do?id=219032
Comment 4 Lou Dasaro 2016-02-15 01:40:50 UTC
Created attachment 158498 [details]
stacktrace

PYTHON:
Occurs at the end of File-> New Project (setuptools)
Built from DEVelopment using "Important Files" patches.
Please assign to JEnselme@netbeans.org
Comment 5 Exceptions Reporter 2016-02-15 01:40:57 UTC
This bug already has 10 duplicates 
see http://statistics.netbeans.org/exceptions/detail.do?id=219032
Comment 6 Jenselme 2016-09-19 15:38:44 UTC
(In reply to Lou Dasaro from comment #4)
> Created attachment 158498 [details]
> stacktrace
> 
> PYTHON:
> Occurs at the end of File-> New Project (setuptools)
> Built from DEVelopment using "Important Files" patches.
> Please assign to JEnselme@netbeans.org

I just created various setuptools projects (Different Python version, with and without main file) on Linux on latest contrib which include the Important files patches, NetBeans is build from the 8.2 branch and cannot reproduce.

Can you or is this solved?
Comment 7 brettryan 2017-04-09 12:58:10 UTC
Created attachment 164056 [details]
stacktrace

Created new Oracle JET QuickStart Basic Application
Comment 8 breebo 2017-04-10 13:02:00 UTC
The descriped Problems cannot be reproduced, so I removed File-Listening and replaced it with an explicit update Action


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo