Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 254187 - Out of Memory exception on JS library CDN
Out of Memory exception on JS library CDN
Status: RESOLVED DUPLICATE of bug 249165
Product: web
Classification: Unclassified
Component: HTML Project
8.0.2
All All
: P3 (vote)
: 8.1
Assigned To: Tomas Mysik
issues@web
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-07 07:49 UTC by coladict
Modified: 2015-08-17 07:45 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
messages.log as pointed to by error message (111.07 KB, text/x-log)
2015-08-07 07:49 UTC, coladict
Details

Note You need to log in before you can comment on or make changes to this bug.
Description coladict 2015-08-07 07:49:56 UTC
Created attachment 155208 [details]
messages.log as pointed to by error message

It hangs and crashes when trying to load JS libraries from whatever remote CDN you have embedded for it.

The stacktrace I get comes at line 1226 of the messages.log it told me to send you.
Comment 1 Milutin Kristofic 2015-08-07 11:31:04 UTC
It would probably needs heap dump for solving this issue, but web.clientproject belongs to HTML Project.

java.lang.OutOfMemoryError: GC overhead limit exceeded
	at java.util.Arrays.copyOf(Arrays.java:2367)
	at java.lang.AbstractStringBuilder.expandCapacity(AbstractStringBuilder.java:130)
	at java.lang.AbstractStringBuilder.ensureCapacityInternal(AbstractStringBuilder.java:114)
	at java.lang.AbstractStringBuilder.append(AbstractStringBuilder.java:415)
	at java.lang.StringBuilder.append(StringBuilder.java:132)
	at org.netbeans.modules.web.clientproject.libraries.CDNJSLibrariesProvider.getFiles(CDNJSLibrariesProvider.java:378)
	at org.netbeans.modules.web.clientproject.libraries.CDNJSLibrariesProvider.createLibrary(CDNJSLibrariesProvider.java:366)
	at org.netbeans.modules.web.clientproject.libraries.CDNJSLibrariesProvider.readLibraries(CDNJSLibrariesProvider.java:220)
	at org.netbeans.modules.web.clientproject.libraries.CDNJSLibrariesProvider.getLibraries(CDNJSLibrariesProvider.java:118)
	at org.netbeans.modules.web.clientproject.api.WebClientLibraryManager.addLibraries(WebClientLibraryManager.java:311)
	at org.netbeans.modules.web.clientproject.api.WebClientLibraryManager.getLibraries(WebClientLibraryManager.java:219)
	at org.netbeans.modules.web.clientproject.api.jslibs.JavaScriptLibrarySelectionPanel$LibrariesTableModel$1.run(JavaScriptLibrarySelectionPanel.java:1257)
	at org.openide.util.RequestProcessor$Task.run(RequestProcessor.java:1423)
Comment 2 Tomas Mysik 2015-08-17 07:45:28 UTC

*** This bug has been marked as a duplicate of bug 249165 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo