Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 253959 - NullPointerException: The lib parameter cannot be null
NullPointerException: The lib parameter cannot be null
Status: RESOLVED FIXED
Product: javaee
Classification: Unclassified
Component: EAR
8.1
All All
: P3 (vote)
: 8.1
Assigned To: Petr Hejl
issues@javaee
EXCEPTIONS_REPORT
:
: 252732 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2015-07-29 17:30 UTC by lehel
Modified: 2015-08-04 01:15 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (2.74 KB, text/plain)
2015-07-29 17:30 UTC, lehel
Details

Note You need to log in before you can comment on or make changes to this bug.
Description lehel 2015-07-29 17:30:09 UTC
Build: NetBeans IDE 8.1 Beta (Build 201507231027)
VM: Java HotSpot(TM) 64-Bit Server VM, 25.20-b23, Java(TM) SE Runtime Environment, 1.8.0_20-b26
OS: Windows 8

User Comments:
lehel: 1. Open wizard for creating Enterprise application project
2. Check Use Dedicated Folder for Storing Libraries and finish the wizard

GUEST: Creating a EEAplication Project




Stacktrace: 
java.lang.NullPointerException: The lib parameter cannot be null
   at org.openide.util.Parameters.notNull(Parameters.java:89)
   at org.netbeans.spi.project.support.ant.ReferenceHelper.copyLibrary(ReferenceHelper.java:1555)
   at org.netbeans.modules.j2ee.earproject.EarProjectGenerator.copyRequiredLibraries(EarProjectGenerator.java:238)
   at org.netbeans.modules.j2ee.earproject.EarProjectGenerator.access$400(EarProjectGenerator.java:113)
   at org.netbeans.modules.j2ee.earproject.EarProjectGenerator$3.run(EarProjectGenerator.java:209)
   at org.netbeans.modules.j2ee.earproject.EarProjectGenerator$3.run(EarProjectGenerator.java:201)
Comment 1 lehel 2015-07-29 17:30:11 UTC
Created attachment 155020 [details]
stacktrace
Comment 2 Petr Hejl 2015-07-30 06:53:17 UTC
*** Bug 252732 has been marked as a duplicate of this bug. ***
Comment 3 Petr Hejl 2015-08-03 10:19:59 UTC
Fixed in web-main 8ba0b2bd9db2. Please verify.
Comment 4 Vladimir Riha 2015-08-03 10:27:02 UTC
Will do, thank you. I'm removing the beta stopper SW, the default wizard works and I would rather not delay Beta due to this issue.
Comment 5 Quality Engineering 2015-08-04 01:15:06 UTC
Integrated into 'main-silver', will be available in build *201508040002* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)

Changeset: http://hg.netbeans.org/main-silver/rev/8ba0b2bd9db2
User: Petr Hejl <phejl@netbeans.org>
Log: #253959 - NullPointerException: The lib parameter cannot be null


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo