Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 253466 - Project level license header is ignored when using the implement interface function
Project level license header is ignored when using the implement interface fu...
Status: VERIFIED FIXED
Product: editor
Classification: Unclassified
Component: Completion & Templates
8.1
PC Windows 7
: P3 (vote)
: 8.1
Assigned To: Dusan Balek
issues@editor
:
: 254410 254830 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2015-07-14 14:20 UTC by IrianR
Modified: 2015-09-23 07:45 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description IrianR 2015-07-14 14:20:07 UTC
[ BUILD # : 201507040001 ]
[ JDK VERSION : 1.8 ]

STEPS:
   * Open a java project with custom license header set
   * Create a brand new Interface
   * Select the interface name and click on the light bulb to show suggestions
   * Select the suggestion to implement the interface

ACTUAL:
   When creating the new interface the custom license is correctly applied.
   When creating the implementation the default License is applied.

EXPECTED:
   In both cases the custom license should be applied.
Comment 1 Dusan Balek 2015-07-16 12:46:21 UTC
Fixed in jet-main.

http://hg.netbeans.org/jet-main/rev/ce4cda7683f5
Comment 2 Quality Engineering 2015-07-18 01:46:54 UTC
Integrated into 'main-silver', will be available in build *201507180001* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)

Changeset: http://hg.netbeans.org/main-silver/rev/ce4cda7683f5
User: Dusan Balek <dbalek@netbeans.org>
Log: Issue #253466 - Project level license header is ignored when using the implement interface function - fixed.
Comment 3 IrianR 2015-07-21 09:02:25 UTC
I've tried to verify this in build 201507200001, but it seems that now the project level license configuration is ignored even for new classes.

I've tried selecting one of the already existing global licenses, and also specifying a project level license file, but none gets picked up.

During the test I've encountered an exception:

 http://statistics.netbeans.org/analytics/exception.do?id=786285 

but I've got it only once so I doubt it's related.
Comment 4 brettryan 2015-08-17 09:18:32 UTC
*** Bug 254410 has been marked as a duplicate of this bug. ***
Comment 5 brettryan 2015-08-17 09:20:50 UTC
I can verify this IrianR's last comment. Creating a new class does not use project specific templates.

Note that my tests are with maven projects.
Comment 6 IrianR 2015-08-17 09:30:48 UTC
(In reply to brettryan from comment #5)
> I can verify this IrianR's last comment. Creating a new class does not use
> project specific templates.
> 
> Note that my tests are with maven projects.

It appears this has been fixed in the latest dev builds, just verified in Build 201508160002.
Comment 7 brettryan 2015-08-17 09:33:30 UTC
Thanks Irian, just waiting to get home to switch from beta to dev builds.
Comment 8 tkellerer 2015-08-29 20:46:24 UTC
*** Bug 254830 has been marked as a duplicate of this bug. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo