Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 253451 - OutOfMemoryError: GC overhead limit exceeded
OutOfMemoryError: GC overhead limit exceeded
Status: RESOLVED DUPLICATE of bug 249165
Product: web
Classification: Unclassified
Component: HTML Project
8.0
All All
: P3 (vote)
: 8.1
Assigned To: Tomas Mysik
issues@web
EXCEPTIONS_REPORT
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2015-07-14 07:44 UTC by crinus
Modified: 2015-07-14 08:29 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (1.71 KB, text/plain)
2015-07-14 07:44 UTC, crinus
Details

Note You need to log in before you can comment on or make changes to this bug.
Description crinus 2015-07-14 07:44:45 UTC
Build: NetBeans IDE 8.0.2 (Build 201411181905)
VM: Java HotSpot(TM) 64-Bit Server VM, 25.40-b25, Java(TM) SE Runtime Environment, 1.8.0_40-b26
OS: Windows 8

User Comments:
GUEST: i am trying to create cordova project for the first time. No javascript library was shown for selection

crinus: Seems I ran into the nagging of about a big 3 gigabyte CDNJS list of the newest javascript libraries. Can I help with this? 

The project I am developing is basically using a lot of JS libraries. I sometimes want to check out the versions. If this CDNJS is the preferable way, I think something could be changed in the way which the list is being processed. Now it seems that NB is choking on the size. Does the whole contents have to be taken or could CDNJS provide polling via service? 

The sheer size of the list / package (I don't know exactly what comes out of CDNJS) gives internal Java errors regarding memory. 

I've registered as Netbeans user.




Stacktrace: 
java.lang.OutOfMemoryError: GC overhead limit exceeded
   at java.util.Arrays.copyOf(Arrays.java:3332)
   at java.lang.AbstractStringBuilder.expandCapacity(AbstractStringBuilder.java:137)
   at java.lang.AbstractStringBuilder.ensureCapacityInternal(AbstractStringBuilder.java:121)
   at java.lang.AbstractStringBuilder.append(AbstractStringBuilder.java:421)
   at java.lang.StringBuilder.append(StringBuilder.java:136)
   at java.net.URLStreamHandler.parseURL(URLStreamHandler.java:253)
Comment 1 crinus 2015-07-14 07:44:47 UTC
Created attachment 154602 [details]
stacktrace
Comment 2 Tomas Mysik 2015-07-14 08:29:07 UTC

*** This bug has been marked as a duplicate of bug 249165 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo